I am on ubuntu 12.04 and forced a shutdown (hardware switch). Now I can't login anymore. In particular, after entering my password I get sent back to the login screen. The error message is to fast for me to read. I am, however, able to login into the Guest account through the usual login screen, and able to login into my own account on tty1 after pressing Ctrl+Alt+F1. What should I try to get back into my own account via the login screen and get back to a working desktop?

Update: I can login with gdm, but not with the (default) lightdm. So the forced shutdown seems to have broken lightdm. The question now is, how do I fix a broken lightdm?

  • Press Ctl+Atl+F1 from login screen. It will open a terminal. Now try to login using your user name and password. Let us know what happen. – shantanu Nov 28 '12 at 4:27
  • @shantanu I can login. I had also tried sudo stop gdm, but it just tells me stop: Unknown instance:. – Earthliŋ Nov 28 '12 at 4:31
  • it's not gdm anymore. It's lightdm. Try sudo stop lightdm and sudo start lightdm – Web-E Nov 28 '12 at 4:50
  • @Web-E I see. stopping and restarting lightdm still doesn't get me past the login screen in lightdm, but I am able to login with gdm, after starting it. – Earthliŋ Nov 28 '12 at 4:55
  • try to reinstall lightdm (sudo apt-get install --reinstall lightdm) after that restart lightdm (sudo service lightdm restart) – shantanu Nov 28 '12 at 8:16

Since you are able to login with gdm try sudo dpkg-reconfigure gdm and select gdm as default display manager.

  • As a workaround. Thanks, that should work. Is there no hope to understand what went wrong with lightdm? – Earthliŋ Nov 28 '12 at 5:05
  • some configuration got changed/corrupted. You can also try to reconfigure lightdm. This kind of problem generally happens when you upgrade from one ubuntu version to another and you have different display manager. – Web-E Nov 28 '12 at 5:24
  • I completely removed and reinstalled lightdm with no change. Could it still be a configuration issue? – Earthliŋ Nov 28 '12 at 8:34
  • removing one component doesn't always remove configs. And what I know lightdm also depends upon unity-greeter. That may also got corrupted. A link for reference. Hopefully we will receive some better answer on this topic. – Web-E Nov 28 '12 at 10:05
  • I also removed and reinstalled unity-greeter. I'll try some of the suggestions in your reference. – Earthliŋ Nov 28 '12 at 10:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.