I am new to Ubuntu and recently installed it on my Mac.

I have ran all of the update i.e.: (apt-get update), and have as well installed the proprietary nVidia driver (nvidia-current-updates).

After having installed that driver, the brightness control stopped working (which seems to be rather common).

I have tried to tackle this issue for a while now, but have been unable to fix it.

I have followed the instructions in this post but to no avail: Brightness controls doesn't work on a MacBook Pro 5.5 (ubuntu 12.04 LTS)

When I run this command: lspci -v | grep -i -A 15 vga

This is what I get:

Capabilities: <access denied>
Kernel driver in use: nvidia
Kernel modules: nvidia_current_updates, nouveau, nvidiafb

I have created and modified the xorg.conf file, and have added the lines mentioned in the other post, I have restarted the computer and pressed F1 and F2 but the brightness of the screen won't budge.

Any ideas what else I could do to solve this problem?

Thank you in advance for any suggestions!

EDIT: I have also tried all 6 steps in this link: https://help.ubuntu.com/community/MacBookPro5-5/Precise#LCD_Brightness_Control as well as https://help.ubuntu.com/community/MacBookPro5-5/Precise#Keyboard (for the keyboard keys)

2 Answers 2


I have a MacBook Pro 7,1 (Mid2010) and have installed the "nvidia-current" drivers.

For me worked the following method:

Type in Terminal:

user@MacBookPro:~$ sudo nvidia-xconfig

I have done that, because the "/etc/X11/xorg.conf" file was missing. After that command it should have been created.

Then open the file:

user@MacBookPro:~$ sudo gedit /etc/X11/xorg.conf

Add in the 'Section "Device"' following line:

Option "RegistryDwords" "EnableBrightnessControl=1"

After that the Section should look like this:

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    Option "RegistryDwords" "EnableBrightnessControl=1"

Then after a restart the brightness controls worked perfectly fine for me.

Hope this helped you.

  • worked on my Macbook6,1 in 12.04... :D
    – Cashew
    Sep 7, 2013 at 16:49

This worked for me. After I was able to edit xorg.conf file. I was constantly denied permission to edit until I followed the commands here

How to change xorg.conf file with permission?

Then I did what was suggested on this post.

Just for reference i'm using a Macbookpro 7.1 running Snow Leopard 10.7

Thank you I was looking for a solution for two weeks.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.