I'm getting this error constantly:

Failure to download extra data files
The following packages requested additional data downloads after package installation, but the data could not be downloaded or could not be processed.


The download will be attempted again later, or you can try the download again now. Running this command requires an active internet connection.

I've tried purging my existing flashplugin, reinstalling it using sudo apt-get install flashplugin-nonfree, tried installing the Firefox Flash plug-in from the software center, and nothing appears to work. Currently running Lubuntu 12.10.


Have you tried installing and using 'Google Chrome' it has flash installed already...

If Flash player doesn't work on 'Google Chrome' you have to do this:

1) If the Flash plugin is already installed for Firefox, we have to find out where it is located:

sudo updatedb
sudo locate libflashplayer.so

2) If it is installed, output should be similar to this one...

falko@falko-desktop:~$ sudo locate libflashplayer.so
/opt/Adobe AIR/Versions/1.0/Resources/libflashplayer.so

... which means the Flash plugin is located in /usr/lib/flashplugin-installer/libflashplayer.so.

3) If there's no output, this means that the Flash plugin isn't installed - you can then install it as follows:

sudo aptitude install flashplugin-installer

4) Now we create a plugins directory for Google Chrome

sudo mkdir /opt/google/chrome/plugins

5) Now copy the Flash plugin to it:

sudo cp /usr/lib/flashplugin-installer/libflashplayer.so /opt/google/chrome/plugins

6) Finally we have to tell the Google Chrome launcher that it should look out for plugins. To do this, we right-click on Applications and select Edit Menus:

Edit Menus

7) In the Menu Editor, go to Internet > Google Chrome and click on the Properties button:

Properties Button

8) In the Launcher Properties window, replace the contents of the Command field with this line...

/opt/google/chrome/google-chrome --enable-plugins %U

... and click on Close:

Command Field

9)Then leave the Menu Editor.

That's it! We can now launch Google Chrome (Applications > Internet > Google Chrome):

Launching 'Google Chrome'

10) If you start Google Chrome for the first time, you'll see this dialogue. Make your choices and click on Start Google Chrome:

'Google Chrome' dialogue

11) Now go to a web site that has Flash videos (e.g. YouTube), and you should be able to watch them which means that the Flash plugin is working:

Testing Flash Player

Hope this helps you and anwsers the question :-)

Good Luck!

Useful Links:

1.http://get.adobe.com/flashplayer/ (In small text you will see click here on this website)


Please click on the tick if this answer helped you!


Per RNA's advice in another post:

 sudo rm /var/lib/update-notifier/user.d/data-downloads-failed

fixed on 14.04.

I removed this file in 12.04 LTS, did not have to re-install flashplugin. Works now, no error message at bootup!

Correction: next day error message came back, tried the purge method and re-installed flashplugin, error message appeared immediately.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.