I like to upload my music to my Google account and I use Google Music Manager to do this.

When I downloaded the music manager the first time, I wanted to actually download all the music I purchased from Google onto my Ubuntu 12.04 Dell Latitude E6400 32-bit. It worked fine and all the music downloaded.

Now I have ripped some of my old cds and want to upload that content to Google. When I chose Google Music Manager from my applications, it pops up in my tray as running but nothing actually happens. When I click on it and chose options which used to open up the interface to chose which folders you wanted to upload and so forth, nothing happens.

I have uninstalled and reinstalled several times and it still does the same thing. I ran it from command line and I see I am getting the errors below.

I intend on asking this same question in a Google forum but I wanted to ask here since I usually get better answers from the Ubuntu community.

t:~$ google-musicmanager

log4cxx: No appender could be found for logger (root).

log4cxx: Please initialize the log4cxx system properly.
  • See the problem is that I can only start music manager. After that I can do nothing with it. I click options, nothing happens so I cannot select a file or do anything with it. I cannot log out of it. I even tried uninstalling and reinstalling and it has me automatically logged in when I start it back up. – LibraryGeekAdam Dec 21 '12 at 20:54
  1. Quit google-musicmanager.
  2. Delete the directory ~/.config/google-musicmanager.
  3. Start google-musicmanager again. You'll get an initial setup wizard again - this time, choose an empty directory to upload music. Then the bug will not be there anymore.

I found this workaround on ubuntuforums.org.

  • I want to download music instead of uploading and choosing the folder explicitly doesn't help – ricab Oct 12 '13 at 13:57
  • 1
    OK, I chose "uploading" with an empty music folder and then I could get to the options and choose download from there – ricab Oct 12 '13 at 14:04
  • Great, this helped solve the problem! – daniels Dec 17 '15 at 17:25

I had the exact same problems, and after deleting google-music-manager from ~/.config it persisted... Until I realized that you have to give Google solid user input on all prompts.

When it asks where to upload from, choose your music folder from the file-tree. Don't just choose the default option. Once I had filled out all boxes and forms, music manager behaves normally, at least in terms of responding to mouse clicks.

I also had to fix a DNS problem, but it's not likely you have that too.

Now if I could only get it to keep downloading my music without quitting halfway through.


Downgrading is the only solution that works for me: google-musicmanager 64bit or google-musicmanager 32bit

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.