I'm installing Maas server with an external dhcp server. I have used Ubuntu Server 12.10 and the MAAS Daily Builds ppa repository.

I have created the admin account and I ran the sudo maas-import-pxe-files command without errors. The MAAS web Interface didn't show any error.

When I run a node with pxe, it enlists in web interface and then I click on accept and commissioning.

I start again the node with pxe, it starts commissioning. It downloads the updates list, after that the node starts to upgrade.

The node status is ready on the web interface,but the node doesn't install the system.

The logs don't show errors, but the file maas.log is empty.

I have the next packages installed:

  • maas
  • maas-cli
  • maas-cluster-controller
  • maas-common
  • maas-region-controller
  • python-maas-client
  • Something I've just learned today is that the node's BIOS needs to be configured to adjust its boot order: 1) PXE, 2) CD-ROM, 3) hard drive. For a Dell this is found in the F2 menu. I was using the F12 menu to temporarily set the boot type but that won't work sometimes during a re-commissioning since the GRUB boot area exists and screws things up. So it would hang on the failed GRUB boot and timeout at 20 minutes. Sep 28, 2015 at 16:25

2 Answers 2


To start with, I would recommend using: daily-qa-ok ppa instead of just the daily builds. The latter has been run through QA rather than just whatever happens to be current trunk.

Most likely the "pserv.log" file will be more interesting than the "maas.log". (IIRC, the former is about the individual machine controllers, while the latter is about the system as a whole.)

Have you actually commissioned the machine? You mention that its status is 'ready' which I believe means it is waiting to be commissioned.

  • I try it, but for this repository a get 404 Not found. I commissioned the node, and the node is ready. But I haven't an operating system on the node. Dec 26, 2012 at 9:02
  • Sorry, I have '404 Not found' error because I'm using precise version. I'll try on quantal version. Dec 26, 2012 at 12:49

FWIW, the new MAAS 1.7 image download process is much smoother, and you should have fewer issues installing the node. You can grab it from this PPA:


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .