I connected a second monitor to my 9800gt on the VGA port. The first monitor is on DVI. Both monitors have a native resolution of 1920x1080 but the second monitor doesn't get past 1360x768 and appears as "Unknown" in the display settings.

I tried this guide on how to add undetected resolutions but it didn't work.

First I create the new mode with xrand --newmode "1920x1080_60.00" 173.00 1920 2048 2248 2576 1080 1083 1088 1120 -hsync +vsync and then when I try to add the new mode to my second monitor like randr --addmode VGA-0 1920x1080 I get this error:

X Error of failed request:  BadMatch (invalid parameter attributes)
  Major opcode of failed request:  140 (RANDR)
  Minor opcode of failed request:  18 (RRAddOutputMode)
  Serial number of failed request:  31
  Current serial number in output stream:  32

I tried using the nvidia-settings panel to generate a xorg.conf:

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"

Section "Files"

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"

Section "Monitor"
    # HorizSync source: builtin, VertRefresh source: builtin
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "CRT-1"
    HorizSync       28.0 - 55.0
    VertRefresh     43.0 - 72.0
    Option         "DPMS"

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce 9800 GT"

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "DFP-0"
    Option         "metamodes" "CRT: 1360x768 +0+0, DFP: nvidia-auto-select +1360+0; CRT: nvidia-auto-select @1920x1080 +0+0, DFP: nvidia-auto-select +1360+0"
                                    ____^____ I tried changing this to 1920x1080 but no luck
    SubSection     "Display"
        Depth       24

Here's my xrandr output in case it helps:

Screen 0: minimum 8 x 8, current 3280 x 1080, maximum 8192 x 8192
DVI-I-0 disconnected (normal left inverted right x axis y axis)
VGA-0 connected 1360x768+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
   1024x768       60.0 +
   1360x768       60.0*    59.8  
   1152x864       60.0  
   800x600        72.2     60.3     56.2  
   680x384       119.9    119.6  
   640x480        59.9  
   512x384       120.0  
   400x300       144.4  
   320x240       120.1  
DVI-I-1 connected 1920x1080+1360+0 (normal left inverted right x axis y axis) 510mm x 290mm
   1920x1080      60.0*+   50.0  
   1680x1050      60.0  
   1600x1200      60.0  
   1440x900       59.9  
   1280x1024      60.0  
   1280x960       60.0  
   1280x800       59.8  
   1280x720       60.0     50.0  
   1024x768       60.0  
   800x600        60.3     56.2  
   720x576        50.0  
   720x480        59.9  
   640x480        59.9  
HDMI-0 disconnected (normal left inverted right x axis y axis)

Any ideas on what to do next? I've been trying for hours with no luck, it works fine in Windows so it can't be the cable or monitor...


I think what you need to do is disable EDID probing. Methods vary depending on graphics chipset/driver. For example, with nvidia’s binary blob driver, you use “Option "IgnoreEDID" "false"”. This goes in your monitor configuration section. YMMV.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.