I'd like to build a machine running Ubuntu and using the new Sandy bridge (i5 2500 specifically) intel cpu's. I heard that 10.10 doesn't have the best support (or simply won't work) with the new cpus and 1155 mobos. I'm assuming that 11.04 will have support but do the alpha's have it already? Or will I have to wait? Also, I plan to use the onboard Intel graphics (H67 mobo), will there be support for this or will I still need to use a graphic's card?


This is Michael Larabel of Phoronix. Sandy Bridge CPU and Cougar Point chipset support under Linux is quite good, sans the graphics bugs and small other hiccups (as pointed out in my articles and already in this thread, don't expect your motherboard to necessarily have LM_Sensors support, there may be some SnR problems, USB3 is generally fine but under some scenarios can be iffy, etc).

In terms of the graphics problems I have noted that some people say is due to a system mis-configuration on my part, that is not the case. Intel's Jesse Barnes is able to reproduce the most severe issue I reported of stability problems / tiling corruption when the system endures enough load. This doesn't seem to happen to everyone or they don't realize it as the system must be under lots of load, but it's happening with at least select ASUS motherboards. I'm waiting on a new board from Intel to see how that goes and how the Linux graphics performance is once everything is working.

  • I'm on sandy/ubu 12.04/linux.3.4.10 and I can say intel driver still have big problem ... I got many visual bug running Never Winter Night 1 ( native ) – Postadelmaga Sep 4 '12 at 16:24

I got the Asus P8P67 Pro and core i5 2500K. I plugged in my old hard drives and it booted right up. The only problems I have found so far are:

  1. Can't suspend with the USB 3 enabled. Unloading the xhci_hcd module resolves that.
  2. No ACPI temperature monitoring, so I had to load the pkgtemp module. Contacted ASUS about fixing this in future bios rev.
  3. No fan control. Contacted ASUS, hopefully they will tell me what chip drives the fan and I can patch lm-sensors to interface with it, or they will add proper ACPI FAN support in the next rev of the bios.
  4. After overclocking, the bios supplied cpu frequency table is wrong. The auto oc option set the base clock to 3.4 GHz with 4.3 GHz on turbo boost, but the ACPI P-state table claims it runs at 5.8 GHz. Contacted ASUS and awaiting bios update.

This is all with Maverick. I will do some more testing with Natty. The one time I did, suspend seemed to work fine without having to unload the USB 3 driver.

FYI, I had an Athlon 64 5000+ Black Edition with dual cores before. That took 22 seconds to build e2fsprogs. New setup takes under 6. I am also using my existing Radeon HD card.

  • 22 seconds to 6? That is sick. I'm scared to think of what the new i7 can do. I'm glad to hear that it boots! – Gu3miles Jan 27 '11 at 1:00
  • Ironically, I can no longer boot my Windows install because the silly Windows fakeraid driver refuses to load without the original controller, but Ubuntu fired right up the first try. Oh well, I had been meaning to delete that silly Windows anyhow. – psusi Jan 27 '11 at 14:11
  • As an aside, to automatically unload xhci_hcd on suspend, add the line SUSPEND_MODULES="xhci_hcd" to /etc/pm/config.d/unload_module. – petergil Feb 7 '11 at 15:37

It is still very bad. ATI catalyst does not work. Even the newest downloaded version. Kernel 3.0-rc5 still did not help. There was a package called acpi_call, that did not work either. After setting "acpi_osi=linux pci=noacpi", it booted normally. I don't know if the fancontrol I installed as service, is working or not, but it runs much cooler than its default setting. However windows 7 is much more cooler than this.

$ lspci | grep VGA

00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)

01:00.0 VGA compatible controller: ATI Technologies Inc NI Seymour [AMD Radeon HD 6470M]

$ lspci -v -s 00:02.0; lspci -v -s 01:00.0

00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09) (prog-if 00 [VGA controller])
    Subsystem: Dell Device 04c1
    Flags: bus master, fast devsel, latency 0, IRQ 25
    Memory at e0000000 (64-bit, non-prefetchable) [size=4M]
    Memory at d0000000 (64-bit, prefetchable) [size=256M]
    I/O ports at 5000 [size=64]
    Expansion ROM at <unassigned> [disabled]
    Capabilities: <access denied>
    Kernel driver in use: i915
    Kernel modules: i915

01:00.0 VGA compatible controller: ATI Technologies Inc NI Seymour [AMD Radeon HD 6470M] (prog-if 00 [VGA controller])
    Subsystem: Dell Device 04c1
    Flags: fast devsel, IRQ 11
    Memory at c0000000 (64-bit, prefetchable) [disabled] [size=256M]
    Memory at e1700000 (64-bit, non-prefetchable) [disabled] [size=128K]
    I/O ports at 4000 [disabled] [size=256]
    Expansion ROM at e1720000 [disabled] [size=128K]
    Capabilities: <access denied>
    Kernel modules: radeon

Here default intel can use only 256M max. That is why my need for speed most wanted would not run. Even the trackballs on ubuntu cannot run. I even tried to install xserver* from edgers ppa, but it did not work. Mine is Dell n4110 sandy bridge. Now I have a very unique problem.

$ glxgears 

Running synchronized to the vertical refresh.  The framerate should be
approximately the same as the monitor refresh rate.

300 frames in 5.0 seconds = 59.821 FPS

XIO:  fatal IO error 11 (Resource temporarily unavailable) on X server ":0.0"
  after 1188 requests (1188 known processed) with 0 events remaining.

See http://ubuntuforums.org/showthread.php?t=1859945 and http://ubuntuforums.org/showthread.php?p=11372380 . There is still not a good support for switching dual graphics (ATI), but after setting up pcie_aspm, turning off ati and using intel hd 3000 (sandy bridge default), installing jupiter, powertop, lm-sensors, i915.i915_enable_rc6=1 and i915.i915_enable_fbc=1 it helped. In the case of rc6 and fbc (frame buffer compression) check if the graphics glitches arises or not. If it does not computer will be more cooler than ever before. If the grapics glitches arises you can disable the last two, still the fan problem no longer exists with other settings. If you had dual graphics card then the one that makes fan burn like fire is the ati card, which can be switched off using vgaswitcheroo.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.