I have a HP dv2745se laptop. I always had Ubuntu with the Native Windows Vista and Wifi worked fine. Suddenly my Ubuntu wouldn't load anymore, I tried fixing it for a week and eventually I formatted its partition and just installed Ubuntu 12.10

This laptop has a Wifi switch that works fine in Vista disabling / enabling the wireless connection. HP Wireless Assistant in Windows say Wireless is on. However, whenever I log in Ubuntu the Wifi button is always orange (disabled) and Wireless never works.

I had this problem once when I had Ubuntu 12.04 and I fixed it by verifying in Windows that the Wireless Assistant showed the Wireless LAN in "On" mode. However, the same does not work now.

I've seen some possible solutions that involve updating the firmware with apt-get. There comes my 2nd problem, my network adapter card is not working and thus I have no internet at all.

Any suggestions? Thanks!


Try opening a terminal and typing rfkill unblock all. If this does not enable your wifi, type lspci find the model of your wifi card and edit your question with the results.


had the same problem. Just go to system>additional drivers and install the Broadcom.

FYI, I will not keep ubuntu on this laptop, has many issues recognizing parts plus frequent freezes. HP made it especially for windows, very few drivers are available eg. your webcam and card reader wont work. Even the display had stripes until set to the correct resolution.



  1. Shutdown and remove the battery.
  2. Hold the power button for a few seconds.
  3. Switch on the power using DC. Do not insert battery.
  4. Press F10 to enter setup. Setup defaults then save changes.
  5. Press the wifi switch.
  6. Reinsert your battery.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.