I have removed the Global App Menu as I prefer to have the minimize, maximize, close buttons on the right side of each app. I did this with no problem in 12.04. I did an upgrade to 12.10 and noticed that Chrome, Chromium and Firefox all use the Global Menu.

I have done the following:

  1. sudo apt-get autoremove appmenu-gtk appmenu-gtk3 appmenu-qt

  2. I have disabled the Firefox extension. I removed the corresponding Firefox package but still only have a global menu.

  3. I tried Gconf but apparently that does not work in 12.10. I then tried Dconf and found this fix on Google: org > gnome > desktop > wm > preferences, look for "button_layout" on the right panel. Here is the problem, after desktop, I do not have wm.

  4. I reset Unity and got a message saying something about wm is missing.

  5. I rebooted and opened Chrome and still no fix. I then clicked maximize and once Chrome was not maximized anymore, the minimize, maximize, close buttons show up in Chrome. Same with Firefox!

Any ideas? I am truly stumped. Firefox and Chrome work fine in KDE Plasma and Gnome when maximized.

1 Answer 1


Let't take it step by step:

  • The reported missing wm is referring to the window manager. Ubuntu 12.10 uses Unity as wm.
  • Instead of autoremove you should use:

    sudo apt-get purge appmenu-gtk appmenu-gtk3 appmenu-qt

I also recommend you to use the unsettings tool to make more deeper customizations. To install it, type:

sudo add-apt-repository ppa:diesch/testing
sudo apt-get update
sudo apt-get install unsettings

After that you can run it with unsettings.


In your case reinstall the uninstalled packages first with:

sudo apt-get install appmenu-gtk appmenu-gtk3 appmenu-qt
  • I followed your instruction regarding purge, instead of autoremove. Unfortunately, that does not work. Specifically wm is not in Dconf after the steps you outlined and the Maximize issue is not resolved (I had it working in 12.04, but I have found no way to get the minimize,maximize, close buttons on any app when it is maximized). I always had Unsettings installed
    – chazdg
    Dec 8, 2012 at 13:38
  • Try to install metacity which is a window-manager (default in older Ubuntus), and see, if that helps you. I assume that you didn't had any other wm-s beside Unity.
    – Frantique
    Dec 8, 2012 at 13:59
  • 1
    I will give it a go. I suspect I may go back to 12.04 as I find 12.10 extremely buggy, but you deserve the 50 points no matter what. No other window managers besides Unity.
    – chazdg
    Dec 8, 2012 at 14:11
  • First give a try with Metacity... Perhaps it helps. By the way, I have switched back as well to 12.04.
    – Frantique
    Dec 8, 2012 at 14:18
  • Well, I installed metacity, rebooted and still no wm in Dconf. Along with the issues with the ATI drivers, back to 12.04 I go! Thank you for looking into this for me. I could not find an answer for weeks.
    – chazdg
    Dec 8, 2012 at 15:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.