2

Asus U31JG - A1 Laptop:

-Intel Core i3

-Nvidia 415m / Intel HD Graphics ( Optimus Technology )


Hello, I have been trying for about 3 weeks now to get any kind of Nvidia driver to work, and now am determined to get the 310.19 driver to work. I have tried numerous times of which either nothing happened or my interface ( menu bars, the top and left bar on desktop, and the ability to close a window) would disappear. Apparently I'm not making the connection on how to get these to install properly. I have tried numerous other posts and websites and attempted "bumblebee" to no avail. I am wondering if anyone can write a step by step guide of commands that I need to run in terminal to get this to work. I've had to reinstall 12.10, so if you could walk me through the process of getting the drivers downloaded and installed, I would greatly appreciate it. I barely know what I'm doing, and this is quite a turn off for someone new to Ubuntu, I really want to enjoy it but this is preventing me from committing. Thank you in advance, and I apologize for being so flustered / helpless with this but I have ran out of patience with this.

1
  • Do you have 'Additional Drivers' installed? You can install Nvidia drivers from there. sudo apt-get install jockey-kde
    – Seth
    Nov 26, 2012 at 23:50

3 Answers 3

1

G'day,

I'm not sure if this will help, but I had a lot of trouble getting graphics drivers working in 12.04 on my Optimus machine.

Here is the procedure I eventually used to get it running smoothly: How do I get a Dell Latitude e6420 working?

I hope this helps.

3
  • I followed the instructions in the comments and it didn't break anything but it says I am using intel Ironlake Mobile. Is this what it should be showing? I think I need the Nvidia GT 415m. Nov 27, 2012 at 22:25
  • Open a terminal and run /usr/lib/nux/unity_support_test --print and paste what the output is. :)
    – David_G
    Nov 27, 2012 at 22:30
  • charles@charles-U31Jg:~$ /usr/lib/nux/unity_support_test --print OpenGL vendor string: Intel Open Source Technology Center OpenGL renderer string: Mesa DRI Intel(R) Ironlake Mobile OpenGL version string: 2.1 Mesa 9.0 Not software rendered: yes Not blacklisted: yes GLX fbconfig: yes GLX texture from pixmap: yes GL npot or rect textures: yes GL vertex program: yes GL fragment program: yes GL vertex buffer object: yes GL framebuffer object: yes GL version is 1.4+: yes Unity 3D supported: yes Nov 27, 2012 at 22:50
0

I had same issue. Turned out it was a missing headers issue.

sudo apt-get install linux-source    
sudo apt-get install linux-headers-generic
sudo apt-get remove nvidia-current   
sudo add-apt-repository ppa:xorg-edgers/ppa
sudo apt-get update
sudo apt-get install nvidia-current-updates
sudo dpkg-reconfigure nvidia-current-updates
sudo shutdown -r now
6
  • I did everything you said and when I logged back in, my interface was missing. The launcher and top "menu" bar Nov 26, 2012 at 2:49
  • did you install different environments to replace unity? Like gnome3 Nov 26, 2012 at 2:54
  • can you open terminal Ctrl+Alt+T unity --reset Nov 26, 2012 at 2:57
  • @Charles Mynard it appears this is a big problem with a lot of people. try from terminal (ctrl+alt+t) sudo dpkg-reconfigure nvidia-current-updates You may have to start from a fresh install if terminal won't open. Nov 26, 2012 at 3:18
  • "Error: the reset option is now deprecated" Nov 26, 2012 at 3:19
-1

there are two possible methods:

  1. Installing the driver from the official Ubuntu repositories ("nvidia-experimental-310") removes bumblebee-nvidia because the package depends on nvidia-current. To avoid this, you need to get the Bumblebee source and repackage the deb with the nvidia-experimental-310 dependency instead of nvidia-current. You may also need to adjust the Primus paths and recompile it.
  2. Add a PPA that uses the nvidia 310 drivers as "nvidia-current" not "nvidia-experimental-310". There are some (like this one: https://launchpad.net/~2nv2u/+... ), but I don't recommend using an unofficial PPA for this. The only official PPA with such a package is, as far as I know, the xorg edgers PPA: https://launchpad.net/~xorg-ed... which has "Xorg packages fresh from git" so it's not stable.

Keep in mind that if you add the xorg edgers PPA, do a dist-upgrade, but you'll get many other packages with the driver (you can't just install the nvidia-current package)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.