I just updated the DNS record (ns1, ns2, ns3.myhostingcompany.com) for a site I've got hosted, but I still get the domain registrar parking page.

I'd like to see if the problem is Ubuntu's cached DNS records. Is there a way to clear Ubuntu's DNS cache? (if such a thing exists?)

  • 1
    Also, check /etc/hosts. I've just been sure that the old IP address of my domain was being cached, but only strace ping example.com revealed that I forgot to remove the /etc/hosts record which I added a time ago because of lacking patience for DNS propagation. – ulidtko Jul 13 '14 at 12:42
  • 1
    a lot of these answers suggest caching is disabled by default, but they also refer older versions. It certainly appears to be on by default in my machine (18.04) and various answers below do show you how to flush it, just scroll down – Madivad Aug 27 at 5:20

13 Answers 13

up vote 52 down vote accepted

For 18.04 and higher

Look at Mike Shultz' answer.

For 11.10 and below

Ubuntu doesn't cache dns records by default so unless you've installed a dns cache there isn't anything to clear.

DNS records are likely cached by your provider's DNS servers so if you want to check if the DNS changes you made were successful you can interrogate a DNS server from your domain hosting service with dig:

dig -t a ns1.myhostingcompany.com @domain_registrar_dns_server

It you want Ubuntu to start caching dns I recommend installing pdnsd together with resolvconf. nscd is buggy and not advisable.

  • 13
    Any references as to why nscd is buggy? Is it still buggy today (2012-10)? – jjmontes Sep 26 '12 at 12:13
  • 2
    Can you update your answer- ATM it sounds like Ubuntu versions 11.10+ do cache DNS records. – Martin Konecny Feb 8 '15 at 3:08

12.04

Ubuntu 12.04 uses dnsmasq which is built into network-manager, but it doesn't cache dns so there is no need to flush it. Here is a sample line from my syslog to prove that point:

dnsmasq[2980]: started, version 2.59 cache disabled

There is also no need for any configuration of dnsmasq. If you are running with stock settings it won't be caching dns, as for it to do so you have to explicitly set it up as this Ubuntu article describes.

If you wanted to refresh your settings you could disable and then enable networking or run

sudo service network-manager restart

This restarts dnsmasq because it is built in to network-manager; check your syslog for the evidence for this.

If you are using a wired connection with dhcp network manager will be taking the settings direct from your router and your connection will be automatically established when you login to Ubuntu. You could check that the settings are correct in your router if you can access it via the web interface, and perhaps reboot it if necessary. If it is a general problem with dns, you could try using Google dns instead of your isp dns, and more information on that is detailed here.

  • sudo service network-manager restart did the trick for me with Debian – Pierre de LESPINAY Oct 28 '14 at 9:01

Note that Ubuntu uses systemd-resolve from 17.04 and onwards so this answer doesn't apply anymore to recent Ubuntu versions. See "flush DNS cache in Ubuntu 17.04 and higher (18.04)"

By default, DNS is not cached in Ubuntu < 17.04 (but it might be cached in the network or application)

To confirm one way or the other whether dnsmasq is caching, run ps ax | grep dnsmasq and look at the running command. Here's a breakdown of my default 13.10 machine:

/usr/sbin/dnsmasq \
  --no-resolv \
  --keep-in-foreground \
  --no-hosts \
  --bind-interfaces \
  --pid-file=/var/run/NetworkManager/dnsmasq.pid \
  --listen-address=127.0.1.1 \
  --conf-file=/var/run/NetworkManager/dnsmasq.conf \
  --cache-size=0 \
  --proxy-dnssec \
  --enable-dbus=org.freedesktop.NetworkManager.dnsmasq \
  --conf-dir=/etc/NetworkManager/dnsmasq.d

/etc/NetworkManager/dnsmasq.d is empty by default. So there aren't any overrides coming in there and just to check --cache-size=0 means what we think it means (instead of an unlimited cache), man dnsmasq shows:

-c, --cache-size=<cachesize>
  Set the size of dnsmasq's cache. The default is 150 names. 
  Setting the cache size to zero disables caching.

So while dnsmasq can cache DNS, it isn't caching out the box. You can check your machine and various configuration directories to check you're on the same page.

If you are seeing cache issues, this is likely happening in one of a few places:

  • Upstream from your computer. Some routers cache. Many corporate networks will cache DNS. Many ISP-run DNS servers and will use their own caches. The only way to guarantee against a network cache is to use a cache you can manually refresh. This is why I like OpenDNS.
  • In the client application (notably browsers). Applications can do all sorts of their own caching that Ubuntu has no effect on. How Firefox caches DNS. How to clear Chrome's DNS cache. Other browsers (and applications) might have their own mechanisms.
  • I'm scraping the barrel here but perhaps you've installed a non-standard DNS server in Ubuntu instead of turning caching on in dnsmasq. There are many: nscd, DJBDNS dnscache (aka TinyDNS), pdns, pdnsd, Bind9 (and its variants), and more I can't even remember. These will probably be evidenced in /etc/resolv.conf (with config in /etc/resolvconf/` to autogen that file). The following shows an locally intercepted DNS query:

    $ nslookup askubuntu.com
    Server:     127.0.1.1
    Address:    127.0.1.1#53
    
    Non-authoritative answer:
    Name:   askubuntu.com
    Address: 198.252.206.24
    

    If you're not hitting 8.8.8.8 (or whatever you expect your DNS server to be), check what you are hitting instead. In my case I can see this is just dnsmasq set up to mirror DNS queries back for LXC, but in your case it might be doing bad cachey things.

    If you have done of the listed caches, the process for clearing each varies:

    sudo /etc/init.d/nscd reload    # nscd
    sudo /etc/init.d/named restart  # bind9
    

On a slightly related note, see this to enable caching in dnsmasq.

  • 1
    My output from ps aux|grep is the same as yours, yet something definitely IS caching DNSs on my machine. If it's not dnsmasq it's something else. Proof: I created a subdomain on my server, yet I could not ping it, host unreachable. I checked at downforeveryoneorjustme.com and it was up, so propagation issue discarded. Not my router, nor my ISP, because I use Google's DNS's 8.8.8.8. Then I rebooted the computer (and NOT the router) and I could reach the domain. I had been retrying a dozen times before reboot with no luck. First try after reboot reached the host. – matteo Mar 17 '14 at 18:00
  • And this was not the first time I experienced the same thing, by the way. Months ago the same happened and the only way I could reach the domain was restarting the computer, but then I had an older Ubuntu version. – matteo Mar 17 '14 at 18:01
  • @matteo The browser? – Oli Mar 17 '14 at 19:00
  • no, as I said I tested with ping, not (only) the browser(s). – matteo Mar 17 '14 at 23:17
  • @matteo I've added more but I'm running out of ideas. There just aren't that many more places somebody could cache DNS :) – Oli Mar 18 '14 at 0:18

For 12.04:

Ubuntu 12.04 does cache DNS using dnsmasq ( see man dnsmasq). Use the following to clear the cache:

sudo kill -HUP $(pgrep dnsmasq)
  • Thank you! You are the first I've seen mention anything about 12.04's default caching! – Tarka Sep 13 '12 at 21:22
  • 5
    12.04 does not cache dns by default- check your syslog after restarting network-manager; it will have an entry that shows dnsmasq is starting with cache-disabled. – user76204 Sep 14 '12 at 21:02
  • 1
    I don't know whether the cache is enabled by default, but this answer worked for me. – jeyk Jan 7 '14 at 23:45
  • Why not just sudo killall -HUP dnsmasq? – James Haigh Apr 20 '14 at 22:13
  • use pkill instead of kill and pgrep – Robert Siemer Sep 9 '14 at 20:45

sudo /etc/init.d/nscd restart

http://www.ubuntugeek.com/howto-clearflush-dns-cache-in-ubuntu.html

Also as a note you can check and see if your DNS changes have propagated using dig and looking up against someone else other than your default DNS servers. In this case google DNS.

dig @8.8.8.8 example.com

  • 11
    Worth noting that nscd isn't installed by default. – Scaine Jan 18 '11 at 20:05

Ubuntu 17.04 and higher (18.04)

From Ubuntu 17.04 and onwards, systemd-resolve is used for DNS. You can flush systemd's caches like so:

sudo systemd-resolve --flush-caches
  • 1
    OMG, will you marry me? Solved my issue with 18.04 too \o/ – NiKo May 8 at 17:37
  • 1
    This didn't work for me on 16.04 LTS - but it was useful to see yet another way it might have been cacheing: sudo systemd-resolve --statistics – Phil May 10 at 8:24

Personally, I'd use OpenDNS and use their Cache Check function to force a refresh just to make sure the changes work but you can't guarantee they'll refresh for your users within 48 hours.

DNS is a slow beast. Patience will keep you sane.

  • +1 I use OpenDNS as well clear cache is very useful. – Mark Davidson Aug 13 '10 at 21:38
  • I'm suspicious of OpenDNS. I was happy with it at first, but then I started getting suspicious; though I guess if it's a choice between ISP and OpenDNS, I'm better off with OpenDNS, right? – Jono Aug 15 '10 at 20:23
  • 1
    I'd say OpenDNS is the lesser evil. They'd like to monetise your traffic but only on bad domain hits. – Oli Aug 15 '10 at 22:35

If you are using nscd:

sudo /etc/init.d/nscd restart

It's worth mentioning that it might not be the OS that is caching it. Everyone likes to cache DNS... Some tests:

Check to see if it's the new or old IP. Most browsers cache DNS as well, so if you haven't restarted Chromium or whatever you might not be seeing the latest.

ping yourdomain.com

Switch your local nameserver in the /etc/resolv.conf to another provider, google or level , examples:

nameserver 8.8.8.8
nameserver 4.2.2.2

And then ping again.

Check to make sure your router isn't caching DNS in any form. (Varies by router/firmware/etc)

Finally, patience. DNS can take a bit of time to propagate throughout the internet.

  • 2
    If using NetworkManager and DHCP /etc/resolve.conf will get flushed when the DHCP lease expires, so you will have to set a static ip in NetworkManager to get this to work over longer time. – LassePoulsen Aug 13 '10 at 21:53
  • +1 I didn't realize Firefox was caching DNS, this helped greatly. – wavemode Dec 22 '14 at 18:57
  • +1 for switching local nameserver to google worked – Bibek Sharma Jan 5 '17 at 7:37

All the answers above forgot one important thing in the name resolution : generally the DNS servers you request the name resolution to is not the one holding the records themselves (the authoritative server). As each DNS record comes with a Time To Live value which will oblige each DNS server in the resolution chain to do caching during the amount of seconds mentioned by this value. So not only you can cache in your machine, but CERTAINLY the result of the name lookup will be cached somewhere on a server you don't control.

The only solution to be immediately notified of a name record change is to use a TTL value of 0 when creating / updating the entry in the authoritative name server. But this means that for each name resolution, the server will be hit, usually this is not allowed by the registrars. For instance, they can provide a list of pre-defined TTL values you can choose in.

I manage different domain names and to be sure that the change are well applied in the authoritative name servers, I'm using a tool called dnstracer that can show the lookup result on each servers from the DNS root.

In conclusion, even without any DNS caching solution in place, there will still be a delay between the moment you change the DNS records and the change is seen on a PC. This delay greatly depends on the TTL of the records and on the number of DNS servers between you PC and the authoritative name server.

  • Of course, but if that was the issue, rebooting the computer wouldn't fix it. – matteo Mar 18 '14 at 14:23

For ubuntu 14.04, I recommand this command :

sudo service dns-clean
  • Not on the default server installs. Only works on 14.04 and below. – R J Aug 31 at 13:58

I used the following command to flush the dns cache on my 12.10 ubuntu box and it worked fantastic.

sudo kill -HUP $(pgrep dnsmasq)

Another helpful signal is the SIGUSR1 which dump a little statistic to syslog or as it is note from man dnsmasq:

In --no-daemon mode or when full logging is enabled (-q), a complete dump of the contents of the cache is made.

  • use pkill instead of kill and pgrep – Robert Siemer Sep 9 '14 at 20:44

I also found contradictions, but this: https://superuser.com/a/521562 woks for me (Ubuntu 13.10 with latest updates, no special network packages installed).
In short, just use this
sudo /etc/init.d/dns-clean

I recommend openDNS specially in remote Ubuntu servers, it eases much pain...

How to do it? Well...

cd /etc/dhcp
sudo nano dhclient.conf

insert this BEFORE the "request subnet-mask..." line

supersede domain-name-servers 208.67.222.222,208.67.220.220;

this will restart the interface so fast that you shouldn't even lose your SSH connection

sudo ifdown eth0 && sudo ifup eth0

check this to see if your brand new openDNS are correctly installed

cat /etc/resolv.conf
  • That's definitely not an answer to the question. – blafasel Nov 8 '17 at 9:33

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.