I currently have 4 workspaces. If I have a pidgin chat window open on one workspace that is currently not active and I get a message in that already open chat window, I want do be able to click on the green envelope symbol in the upper menu-bar and be switched to the workspace the window is situated. Currently if I click on the green envelope symbol there will be appear a button on the lower menu-bar on which I have to click to be switched to the other workspace.

Same with opening links. If in some application I click on a link the last activated Firefox window will open the link. Even this last active firebox window is on a currently not active workspace, and there is a Firefox window on the currently active workspace. So either open the link in the Firefox on the currently active workspace, or switch to the workspace on which the link was opened.

Is/are there any solution(s) to this problem?


1 Answer 1


You could try this, if you haven't installed compiz settings manager, then do so by running:

sudo apt-get update
sudo apt-get install compizconfig-settings-manager

Once it's installed, click System > Preferences > Compiz Settings Manager

Then go to Focus & Raise Behaviour > General and set Focus Prevention Level to Off

Tested on Ubuntu 16.04.

  • I can't find any setting that satisfies what I'm searching for.
    – Pit
    Apr 1, 2011 at 7:56
  • 1
    In 12.04, setting the Focus Prevention Level to Off (default is Low) makes this work for me.
    – zpletan
    Nov 12, 2012 at 2:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.