15

I just purchased the Asus Zenbook UX31A and I require some advice regarding tuning the touchpad.

Basically my problem is that the mouse buttons are withing the touch area and I would like it to be disabled. Such that only part of the touch area is recognized. I have attached an image to clarify the idea. Basically only the red area in the image should be recognized.

touchpad tweak

I have two reasons for this request: Firstly, I like to hold my thumb on the mouse button instead of holding it in the air. This is problematic, because touchpad thinks that I'm trying some kind of two finger gesture all the time and cursor stops moving.

Clicking is also problematic since every finger movement -- regardless of how insignificant it might be -- on the "button" will move the cursor.

I have been playing with some synclient settings like AreaBottomEdge etc. They have some effect but then I cannot highlight text or right button stops working.

How could I solve this?

1
  • 1
    There is a setting in System settings that enables you to deactivate clicking by touching the touchpad. Perhaps that can solve your problem? Commented Nov 29, 2012 at 11:27

2 Answers 2

11
+50

It is very simple to accomplish this:

First discover the width and height of your touchpad typing in the terminal:

less /var/log/Xorg.0.log | grep -i range

In my case the output was this:

[    24.188] (--) synaptics: SynPS/2 Synaptics TouchPad: x-axis range 1472 - 5772
[    24.188] (--) synaptics: SynPS/2 Synaptics TouchPad: y-axis range 1408 - 5086

So the width is 5772 and the height is 5086. Now you can have a notion of the bottom area to disable, just try out values to get the desired area disabled. The command in the terminal is:

synclient AreaBottomEdge=**VALUE**(in my case 730)

That is all.

8
  • Unfortunately this does not help. It does decrease the area, but then text highlighting and right mouse button stops working.
    – M.L.
    Commented Dec 22, 2012 at 18:33
  • So the right mouse button, is it a real button? I mean, it makes like, it needs to be pressed? Or it is a touch-button, that you need no presssure? Because mine, that need pressure, still works after reducing touchpad area, but if the button works with the touch technology it may be almost impossible to accomplish what you are intentioning to do. Commented Dec 22, 2012 at 19:45
  • 1
    In my case it helps, but with the following side effect. while holding one finger on the button (already inactive area) and moving the other over the active area either nothing is happening or scrolling is occurring.
    – citxx
    Commented Dec 24, 2012 at 20:07
  • Sorry, but I won't be able to help you any further than this, I just know this solution. Commented Dec 26, 2012 at 11:46
  • 1
    Thanks. I'll try to investigate further this problem myself.
    – citxx
    Commented Dec 26, 2012 at 17:07
2

For me, doing this was not enough. I needed to let my thumb at the bottom of the touchpad (ready to click). Actually, the AreaBottomEdge don't disable the "finger counting" on the dead zone and resting your thumb enable the scroll. Quite annoying.

To fix that, I used this patch : http://pastebin.com/raw.php?i=4v9JP2pe

Don't forget to change to the AreaBottomEdge value in /etc/X11/xorg.conf.d/10-synaptics.conf

Source : #24

Edit: by the way, the bug is referenced here : https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-input-synaptics/+bug/1026046

1
  • Spent a long time trying to get my touchpad to this state, where I could actually have my finger on the bottom ready to click and the 'Tweaks' Touchpad settings worked. Ended up uninstalled all synaptics related drivers and having libinput handle it, which worked finally
    – gen
    Commented May 16 at 1:25

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .