I'm a bit long-winded so see bottom for quick version and specs.

Friendly Hello:

Hello all on these askUbuntu pages, I just recently built my own computer and decided to switch to Ubuntu for the extra coolness. I've been learning a lot through all this, and mostly been trying to figure out issues on my own (read: Google searches). However, I couldn't seem to find others with this problem so I've come here for help.

Detailed Recount:

So I just used WINE and WINETRICKS to install Steam. All went well and it worked. Then I went to trying a game out. I remembered that Orcs Must Die! worked from http://www.steamgamesonlinux.com/ so I tried that out. After selecting to download it, that's when the problem occurred. The screen suddenly zoomed in!!! I think it's the resolution right? Half the screen is cut off and I can't see parts of the right side of windows. My theory is that this is due to Direct X being installed through Steam, as Steam automatically installed it as I chose to download the game. It didn't even ask me to install Direct X or not ): It all happened so fast. This all being said, the game works fine! It looks a little strange, as if the resolution was off, but it plays just fine.

What I did so far:

Restarted my computer. Didn't work -_- Researched Steam installing DirectX on Ubuntu then messing up resolution and couldn't really find anything. Researched uninstalling DirectX from Ubuntu but only found uninstalling DirectX after having been installed with Wine, not through Steam. Got mad and ate my feelings. Tried "xrandr -s 0" but it didn't do anything. Ran xrandr alone and terminal showed this: Screen 0: minimum 8 x 8, current 640 x 480, maximum 16384 x 16384 DVI-I-0 connected 640x480+0+0 (normal left inverted right x axis y axis) 0mm x 0mm 640x480 59.9*+ 320x240 120.1 DVI-I-1 disconnected (normal left inverted right x axis y axis) HDMI-0 disconnected (normal left inverted right x axis y axis) DP-0 disconnected (normal left inverted right x axis y axis) DVI-D-0 disconnected (normal left inverted right x axis y axis) DP-1 disconnected (normal left inverted right x axis y axis) About now I was mad so I played Odin's Sphere then took a nap. Back to it! I entered the following: xrandr --output DVI-I-0 --mode 1024x768 But I was met with this message: xrandr: cannot find mode 1024x768 I get the same messages for 800x600, 1400x1050, and seemingly any other combination of numbers. I then tried Going into System Settings then Displays, then playing around in there. My Resolution is set to 640x480 and there are no other options for me to choose from. Rotation has Normal, Clockwise, Counter Clockwise, and 180 Degrees. It's set to Normal and I haven't messed with that. Launcher Placement has Unknown and All Displays as its two options. It's set to Unknown, but moving it to All Displays doesn't seem to do anything. Finally, when I click Detect Displays, nothing seems to happen.

Quick Version:

Linux noob. Steam installed with Wine and Winetricks. Steam downloaded and installed game + DirectX. Resolution messed up now (I think; pretty sure), can't fix it, very annoying, no idea what's going on, halp!


Ubuntu Version 12.04 Wine Version 1.4.1 Have not changed any settings in Wine Using Winetricks Graphics Card: http://www.gigabyte.com/products/pro...px?pid=4361#sp Drivers: Proprietary (Installing those were a LOT of fun) Also let it be known that I have a DVI to VGA cord running from my Graphics card to my monitor. If any more information is needed I am ready to report.

Thank You:

Thanks a lot for your help and all the work you do to support noob ubuntuers like me (:

  • 1
    ok - before messing around with wine - can you try the official linux steam client and let us know how you get on? askubuntu.com/a/213833/14356
    – fossfreedom
    Nov 25, 2012 at 11:02
  • This haunted me 10 years after... The answer isn't relevant anymore (at least it doesn't work for me), your attempts noted in this question actually helped (xrandr -s 0 worked for me). Thanks for asking and answering this for me :)
    – 0xc0de
    May 4, 2022 at 10:03

1 Answer 1


I am assuming you mean the xorg resolution is messed up not just the games.

If it is the whole xwin settings I would move the xorg.conf to xorg.bad and recreate it. see if no config works normaly. if no you can run the nvidia config (im assuming nvidia card) and have it recreate the xorg.conf. I have had some games mess the primary screen up and wasnt able to get in to the video mode app to restore it. xorg.conf was the only way to resolve that.

If its the game its self I have seen that to. you may need to kill some .conf or ini files in the game. some times I have had to edit them and forcefully change it to the resolution that works best for me. other games dont have a conf and you either get lucky or not. startopia was like that. I always try an make a backup of the initial good ini files from install and or first run where every thing works right. its not unusual to have to restore settings for some of the pickier programs.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.