Out of a sudden after I logging in to the 'Ubuntu' session Unity or maybe Compiz doesn't start anymore (actually I'm not sure wether it is Compiz or Unity). I can start Unity manually with setsid unity & and put the command as a startup script but that's not how it should be.

I also tried a lot of "solutions" but none of them helped:

  • checked for activated 'Unity' module in ccsm
  • reinstalled lightdm
  • reset Compiz and Unity
  • reinstalled all Compiz/Unity packages
  • many more...

The question now is, how do I get Compiz/Unity to be started propperly at login again?

I'm on 12.10 with Intel graphics.


You just have to add one startup application:

  1. Open a terminal and type the following command:

    unity && compiz --replace
  2. If step 1 works for your situation, open unity-dash-home and type startup. You should see Startup Applications.

    In the program, add a startup application with the command:

    compiz --replace
  3. Log out and login, things should be solved.

| improve this answer | |
  • Meanwhile I got a new Laptop which 'solved' this problem by a clean install. Sadly this is only a workaround which for me worked only when I put a big pause in the startup script. So what I was really interested in was to know the reason why Unity/Compiz didn't start as intended and how to get evrything working fine without a workaround. – joschi Jan 29 '13 at 15:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.