It appears as though many people are having problems installing Ubuntu along side Windows 8. My problem, however, seems to be sufficiently different to be unique among such problems. I can't get the Ubuntu 12.10 live-USB installer to run. When I boot I get the following four options:

  • Run from this USB
  • Install to disk
  • Check memory
  • (I can't remember the last one)

I have tried the top two. Both result in the screen going black briefly then windows 8 booting as per usual. Does anyone know how I may manage to overcome this problem?


If you are making a bootable USB drive, use UNetBootin or Universal USB Installer.

UNetBootin download

Pendrive's Universal USB Installer

Locate your Ubuntu ISO file and make sure that you select the right USB drive because it will format and erase ANYTHING on that USB Drive. Click on "My Computer" and double check to see if it is the right USB drive.

(If doing this on a hard drive, select "Show Hard Drives" or "Show All Drives" and then select the Hard drive.)

If you are making a bootable CD or DVD, use PowerISO. PowerISO is commercial software though, but the trial version will work fine.

PowerISO download

Open your ISO Image File and up on the top of the program, Click "Burn to Disc". Use the default burning speed for your drive, which is already preselected for you.

If neither works for you then the Ubuntu Installer does not yet support Windows 8 or you have a corrupt or damaged Ubuntu ISO File. (I think Ubuntu's Installer doesn't yet support Windows 8.)

  • I too think this is a case of incorrectly created live usb drive. Use the latest version of Universal USB installer, this one has worked the best for me for many years now. – Sagar_R Nov 24 '12 at 16:37
  • I myself use UnetBootin, but Universal USB install is simpler for new linux users. – Teddy Thorpe Nov 24 '12 at 18:11
  • I ended up using UnetBootin. Worked great. I was using the Ubuntu recommended tool before. – Jake Nov 25 '12 at 0:06
  • I used to use Universal USB installer. I had no problems with it but, when I tried UnetBootin, I just couldn't go back to USB Installer. I'm not saying its bad, but I wanted something more advanced. – Teddy Thorpe Nov 26 '12 at 1:47

Sounds like your USB was not created correctly.

You could either :

  1. Re-create your USB
  2. Use a DVD

DVDs have always been more reliable for me

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.