I have been using Ubuntu 11.04 on DELL Inspiron 14R (N5010) laptop for last three months. Before I switch to Ubuntu my laptop battery used to give 2.5 hrs to 3 hrs back-up. But since I have been using Ubuntu, it has been reduced to 1hr to 1.5 hrs at max.

I tried following commands:

cat /proc/acpi/battery/BAT0/state

Which gave result as:

present:                 yes
capacity state:          ok
charging state:          charged
present rate:            1 mA
remaining capacity:      4400 mAh
present voltage:         12407 mV

Then I tried acpi -b, that resulted in:

Battery 0: Unknown, 100%

When I gave command as upower -i /org/freedesktop/UPower/devices/battery_BAT0

native-path: /sys/devices/LNXSYSTM:00/device:00/PNP0C0A:00/power_supply/BAT0

model:                DELL W7H3N08
serial:               7114
power supply:         yes
updated:              Sat Nov 24 11:25:34 2012 (21 seconds ago)
has history:          yes
has statistics:       yes

present:             yes
rechargeable:        yes
state:               fully-charged
energy:              48.4748 Wh
energy-empty:        0 Wh
energy-full:         48.4748 Wh
energy-full-design:  48.9595 Wh
energy-rate:         0.011017 W
voltage:             12.408 V
percentage:          100%
capacity:            52.9253%
technology:          lithium-ion
  • Someone please let me know, what is going wrong with my laptop?
  • How can I get charging with full capacity?
  • Can you supply the output from running: cat /sys/class/power_supply/BAT0/uevent then we can see exactly what the battery is informing the operating system via the ACPI _BST, _BIX (or _BIF) controls. From that we should be able to deduce if the battery is fully charged or if a cell has died. – Colin Ian King Nov 24 '12 at 10:27
  • can you charge full capasity when laptop close ? – user84277 Nov 24 '12 at 10:31
  • I'm having a similar issue in which I have installed a new battery that will not charge to it's full capacity. I'm looking for a manner to change some setting in which Ubuntu will allow a full charge, I have a feeling that this has to do with a design in Ubuntu that may be improved upon and is not an issue with Batteries. POWER_SUPPLY_STATUS=Discharging POWER_SUPPLY_PRESENT=1 POWER_SUPPLY_TECHNOLOGY=Li-ion POWER_SUPPLY_CYCLE_COUNT=0 POWER_SUPPLY_VOLTAGE_MIN_DESIGN=23644000 POWER_SUPPLY_VOLTAGE_NOW=23644000 POWER_SUPPLY_CURRENT_NOW=1995000 POWER_SUPPLY_CHARGE_FULL_DESIGN=6000000 POWER_SUPPLY_CH – user139557 Mar 12 '13 at 1:03

Kindly go through the ACPI Problem and regression problem occured during the period from the ubuntu 10.10, 11.04 and 11.10.. Try to install the ubuntu 12.04 or the newer version . Or else check with the installing the Jupiter app. which is mainly developed eee asus .

  • Installing jupiter will not get to the root cause, that is a distraction from solving this user's problem. – Colin Ian King Nov 24 '12 at 10:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.