My desktop computer has two drives each with two partitions apart from swap, boot. /dev/sda1 has Windows XP,programs and some data; sda2 and sdb1 have only data: sdb2 (40GB) has Kubuntu 12.04.01.

After I installed Kubuntu some four weeks ago I put five shortcut items on my desktop by: Unlock widgets, drag files to desktop corner and select "icon". ShortcutA was to a subdirectory on sda1, B was to a subdirectory on sdb1, C was to a file on sda1, D and E were to files on sdb1. By clicking on the icon, I could open the file in the same way but quicker than navigating through Dolphin or other file manager. There are three users; in Kubuntu, only I can access files outside sdb2. To enable this, lines were added (partly with help from this forum), to etc/fstab :

/dev/sda1       /media/Windows ntfs-3g defaults,rw,uid=1000,gid=1000,umask=0077 0 0
/dev/sda2       /media/Temp ntfs-3g defaults,rw,uid=1000,gid=1000,umask=0077 0 0
#/dev/sdb1       /media/Data ntfs-3g defaults,rw,uid=1000,gid=1000,umask=0077 0 0
/dev/fd0        /media/floppy0  auto    rw,user,noauto,exec,utf8 0       0

Because the sdb1 line was commented with #, a spurious mountpoint /media/Data_ was created (in addition to /media/Data, and it was necessary to amend the paths on shortcuts B,D and E to get them to work. On eventually uncommenting the command, /media/Data_ disappeared, and the shortcuts were deleted. On their reinstatement with corrected paths, shortcutB worked, but D and E did not. A and C have worked throughout.

I have also tried the method in How to Add a Shortcut On Desktop. but this doesn't help.The only changes made to the system, apart from accepting the new Linux Kernel, are as above. I would be grateful for advice on how to get my shortcuts working again.

  • To clarify, are you using symbolic links or .desktop files? My answer will vary depending upon the method. – thirtythreeforty Nov 27 '12 at 5:03
  • I have just seen in System Settings>Workspace Appearance and Behaviour>Desktop Effects a message saying "Desktop Effects are not available on this system. OpenGL compositing (the default) has crashed in the past." – WGCman Nov 27 '12 at 8:47
  • gh403, thanks for response. I don't know the answer to your question - how do I find out? If I right click the icon, then click the spanner, the File type application/x-desktop dialog starts "Filename patterns: *.desktop *.kdelink" in that order. Does this help? – WGCman Nov 27 '12 at 8:58

There are three possibilities.

  1. If you have a symbolic link (the text of the icon will be in italics if it is), there isn't a lot you can do to modify it. It's easier to delete it and start over.

  2. If you created the shortcut as a widget (by dragging a folder to an empty desktop, as shown)

    Creating a widget shortcut

    then you can edit ~/.kde4/share/config/plasma-desktop-appletsrc to change its path. For example, I created a VirtualBox icon widget on the desktop, and it shows up in plasma-desktop-appletsrc thus:


    If I wanted to change this to point to Firefox instead, I'd just change the URL line to


    (obviously, change the path to your desired one) and save (you might need to log out/in).

  3. The third type of link is the *.desktop shortcut; these are a lot like Windows's *.lnk files. It turns out that Linux's *.desktop files are actually just text files, and can be edited! The thing to do is to right click it and choose Open In > Kwrite or Open In > Kate (if you have Kate installed).

    Editing a Firefox .desktop file

    You can ignore all the names that appear (if you have an application), but look for the Exec= line near the bottom. If you have a folder shortcut, the line will be URL= instead. You can change this to whatever you like.

    When you save and close, KDE may mark the file with a little warning symbol. This is normal and means that KDE doesn't know that the file is safe to launch. If you click on it, go ahead and accept the warning that pops up.

    Untrusted Firefox

    Launch anyway

  • Thanks gh403. It may be relevant that my desktop wallpaper is a slideshow. - perhaps I should have mentioned this before. I see no italicised text either on the shortcuts A,B&C which work or D&E which don't. I get a different dialog from what you describe. Left click opens the file for A,B&C or widget bounces for D&E for a few seconds then disappears.. Right clickfor ABCD&E reveals nothing that I can view, let alone edit by Kate (which I have). First dialog box on Rt-Clik gives options 1Icon Settings, 2 Desktop Effects, 3 (only if widgets are unlocked) Remove this icon.... – WGCman Dec 2 '12 at 8:58
  • …. Selecting Icon Settings option leads to another dialog box which describes icons A&B as “folder”, and C,D&E as “desktop configuration file”. (Please remember only A,B&C work). The dialog box has five tabs: General, Permissions, Application, Information and Preview. Altering the name and command in the Application box doesn't help, but there is also a “spanner” on the General tab with two tabs: General and Embedding, the first of which I described above. – WGCman Dec 2 '12 at 9:11
  • It would seem that you have created KDE Plasma widgets, as opposed to .desktop files. I just realized how to edit those; I'll edit my answer above. – thirtythreeforty Dec 3 '12 at 17:38
  • Thanks again. but I feel there could be some misunderstanding here. If I want to open a program quickly, I simply unlock widgets and drag its icon to a panel at the bottom of the screen. I never open Firefox any other way. The shortcut items to which I referred in the second paragraph of my first message above are simply files; in the case of "B" (which still works) it is a file called budget.ods; I click on the Icon, and Libre Office opens the spreadsheet instantly. Such icon's aren't accepted on the panel and in any case thereisn't enought room on the panel. – WGCman Dec 3 '12 at 21:29
  • Before I amended 'fstab' as described above, I had two other shortct icons – WGCman Dec 3 '12 at 21:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.