I installed Xubuntu and transmission daemon, set the download path to my home/user/TV shows, and get a permission denied when trying to download torrents through the transmission.

I tried chmod -r 777 on this folder without success.

Please help!

Following is the output of ps -ef | grep transmission

chen@htpc:~$ ps -ef | grep transmission
109       1023     1  1 21:46 ?        00:00:35 /usr/bin/transmission-daemon --config-dir /var/lib/transmission-daemon/info

chen@htpc:~$ ps aux | grep transmission
109       1023  3.2  0.4  47684 16620 ?        Ssl  21:46   1:20     /usr/bin/transmission-daemon --config-dir /var/lib/transmission-daemon/info
chen      1852  0.0  0.0   4200   772 pts/0    S+   22:27   0:00 grep --color=auto transmission

enter code here
  • Can you add the output of ps -ef | grep transmission to the question. I don't think transmission-daemon has the right to write to home dirs by default. Nov 23 '12 at 20:09
  • I added it, how do I add permissions to this user ? Nov 23 '12 at 20:18
  • Well, I was after the name of the user it runs under, but it's not shown. Try ps aux | grep transmission instead. Nov 23 '12 at 20:25
  • Hm..., it looks like its username it 109 - kind of odd. Nov 23 '12 at 20:39
  • This is really bizarre, but it should be running under debian-transmission, not sure why it shows a stupid number. You can verify that with id debian-transmission. Nov 23 '12 at 20:46

13 Answers 13


Assuming the path to the download folder is /home/chen/TV shows, run the following:

  • add chen to the debian-transmission group

    sudo usermod -a -G debian-transmission chen
  • change the folder ownership

    sudo chgrp debian-transmission /home/chen/TV\ shows
  • grant write access to the group

    sudo chmod 770 /home/chen/TV\ shows
  • Stop the deamon with

    sudo service transmission-daemon stop
  • The last thing to do is change the file creation mask, so that the downloaded files would be writeable by chen.

    sudo nano /etc/transmission-daemon/settings.json

    … and change "umask": 18 to "umask": 2. Hit Ctrl+O to save and Ctrl+X to exit.

Start the daemon with

sudo service transmission-daemon start
  • In case anyone tries to cd into their directory right after doing this and receive a permission denied, logout and login again. My SSH session did not have the right permissions to access the folder after folder ownership was given to debian-tranmission group (since my user wasn't added to that group until next logon) Aug 11 '15 at 6:37
  • This works up until I need to create a new folder (e.g. the torrent's files are nested). Then I get another permission denied.
    – GDorn
    Mar 21 '16 at 19:00
  • @GDorn That shouldn't be the case. "umask": 2 translates to permissions of 774, or rwxrwxr--, which means fool access for owner and group. Mar 21 '16 at 19:17
  • Useful answer, but, maybe, I can suggest an editt to the answer: I had troubles with /var/lib/transmission-daemon/.config/transmission-demon/torrents. This directory didn't have write permission. Changing them all stated to work.
    – LPs
    Dec 30 '16 at 22:09
  • @GDorn you can use chmod -R to make the command recursive May 3 '20 at 22:22

This is a permission issue based on the user ID that is running Transmission. Transmission sets up a default user that you might not expect on first install. The user name is debian-transmission.

I will explain how to change that:

  1. Stop the Transmission daemon sudo service transmission-daemon stop
  2. Open the Transmission config file for editing: sudo nano /etc/init.d/transmission-daemon
  3. Find the line that says USER=debian-transmission and change it to the user that owns the folder in question. If you are not concerned about security issues, you can also use USER=root in this file. (Not advised, but good for troubleshooting).
  4. Alternatively (instead of point number 3), modify the /etc/fstab folder to mount the folder with correct permissions for the user that runs the transmission-daemon.
  5. Start the Transmission daemon sudo service transmission-daemon start
  • 2
    That won't work. Here either the user transmission-daemon or root also owns "/var/lib/transmission-daemon/info/settings.json" and if you change the daemon to run as $USER , it will give Couldn't read "/var/lib/transmission-daemon/info/settings.json": Permission denied. It somehow worked in your system , But this is not the proper way to do it. Mar 15 '16 at 10:15
  • 1
    It works, thanks. And if your using systemd you should edit the User under [Service] at /lib/systemd/system/transmission-daemon.service.
    – zer09
    Nov 23 '19 at 10:09

Check if you're using an "incomplete" folder. The error can be misleading in this case and it may be the incomplete folder you do not have write access to.

  • 2
    that was my case: in the settings I had a wrong case for the incomplete dir. So the error was doubly misleading: the error was not in the directory the error was telling and the error should have been "not found" and not "permission denied" Aug 1 '16 at 9:05
  • 2
    This was my problem! It had reset to /root/incomplete, which obviously isn't writable!
    – Pez Cuckow
    Apr 30 '18 at 17:27
  • 1
    What @RiccardoCossu said. Can't upvote enough.
    – rocketboy
    May 1 '18 at 13:32

This just happened to me. I found this page, was intimidated by all the jargon, so I restarted Transmission, reserved the torrent file to a different location, and saved the torrent data to the same different location (desktop). Worked like a charm...


This might be an apparmor profile problem. Transmission runs under the sanitized_helper profile in apparmor.

Look for complaints in /var/log/kern.log. grep transm /var/log/kern.log, particularly just after trying to run transmission and it failing.


Since this is the top search result in Google, for anyone reading this, I spend over an hour trying to get it to work. Turns out, the downloads folder specified in settings.json is "Downloads" instead of "downloads". Note the case.


In my case the problem was how the drive was being mounted. Using this in /etc/fstab worked for me:

UUID=2069-1A05  /mnt/ext   vfat   rw,user,exec,umask=0000   0   0
  • 1
    A bit of context might help here (vfat? Not a typical Linux filesystem) - what was your scenario, what exactly was not working and how did this fix it?
    – Zanna
    Jan 2 '17 at 21:37

Make sure that the path for your incomplete torrents is absolute. My main directory was using ~/path-to-download, which gave me an error. My incomplete directory was ~/path-to-download/incomplete.

I received an error the first time I tried to download a torrent not using an absolute directory. I fixed that, but kept receiving a permission denied error, even after adding the correct permissions. Once I fixed my incomplete path to an absolute path, everything worked.


my problem was that transmission somehow was running as the user "transmissions-daemon" instead of the user it was supposed to run with.


Mounting the external drive into my home directory resolved this issue;

sudo mkdir /home/plex/media-server
sudo chmod 770 /home/plex/media-server
sudo mount /dev/sdxx/ /home/plex/media-drive

sdxx is the name of your hdd. you can use the following command to find yours:


Try this:

sudo setfacl -m u:debian-transmission:rxw  /home/*your user*/*your path to folder*
  • 1
    Welcome to Ask Ubuntu! If you edit this and add a little more explanation on what this command does and how to undo it if it does not work, it would be more helpful.
    – guttermonk
    Sep 20 '20 at 16:19

I had same issue, and that was a mistake I had made when sym-linking the transmission download directory to my home/user/ directory, I changed the ownership of the sym-linked file which by consequence also changed the ownership of the transmission 'download' directory...

I just chowned back to 'debian-transmission' ownership and it worked like a charm (without need to restart service)

#chown debian-transmission:debian-transmission /var/lib/transmission/downloads

(well, you'll have to check according your own linux distribution what is the right owner and eventually also your right path to the downloads directory)


I had similar issue with transmission. I got Permission Error while downloading even with correct folder permission settings on the external USB HDD.

I just mounted the external HDD to the /home/pi/ with the same permissions and it worked fine.

mount /dev/sda /home/pi/USB-HDD-MOUNTED

permissions are drwxrwxrwx (0777) pi:debian-transmission. user name is changed to pi in /etc/init.d/transmisssion-daemon.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.