1

and thank you kindly for you help!

I'll preface this with saying that I realize this is a common problem, with lots of trouble-shooting guides available online; however, after multiple attempts with different guides, I've made zero progress and am hoping to someone could help me with my specific scenario.

First, my story: -Initially, I installed Ubuntu 12.10 with the "Something Else" option with no problems. Used 4 GB Swap Logical Partition, 26 GB Primary Root Partition. Wanting to trying out Mint 13, I booted into Windows from GRUB2, used the latest version of EasyBCD (v2.2) to restore the Windows 7 bootloader to the MBR, deleted the Ubuntu partitions, reformatted them in NTFS. I then created a 30 GB partition of free space for Mint.

I installed Mint using the same partitioning described above for Ubuntu 12.10, using /dev/sda for the boot installation files, and everything seemed to go well, until I re-booted my computer and it went straight to Windows - I could find no way to get into Mint. So I went into windows, restored windows bootloader to the MBR w/ EasyBCD, deleted partitions, etc., as I figured I'd done enough messing around and would go with Ubuntu 12.10.

Now the problem: I restarted my computer booting from the same Ubuntu USB key I originally used. Briefly, "error: "prefix" is not set" flashed on screen, and instead of being greeted with the GUI menu of "try vs. install Ubuntu", there was a menu with minimal graphics (like a BIOS menu) where I could select install, run from USB, etc. After selecting "Install Ubuntu", the familiar install wizard with a GUI came up, I partitioned my drive as described, /dev/sda for the boot installation files, install went well, rebooted and...straight to Windows. This is where I'm at.

Fixes I've tried: -This guide: How can I repair grub? (How to get Ubuntu back after installing Windows?) to ensure Grub is on the MBR. I followed all steps, but still when I reboot, I go directly into Windows.

-Installing 12.04 instead of 12.10 - same issue

-Re-installed Ubuntu, writing the boot files to their own partition, then using EasyBCD to to add a boot option for Ubuntu using the Windows bootloader, ensuring I instruct EasyBCD to look at the partition I created with the Ubuntu installer (instructions here http://neosmart.net/wiki/display/EBCD/Ubuntu). When I reboot, I select the Ubuntu option, and it puts me in GRUB4DOS, with a cursor waiting for input. I have no idea what to put here, so I would just type "reboot" to exit out.

And this is where I am now. Any clue as to why I can't boot into Ubuntu?

My computer specs are: ASUS UX31A Core i7, Win 7 64 Pro, 256 GB SSD, Intel HM76 Chipset and Integrated Intel HD 4000 Graphics, 4 GB memory

I've tried to be as clear as possible, but I'd be happy to provide any info that would help anyone along. Thanks for your patience in reading this!

Sincerely,

-MN

3
  • Please add to your question how the disk is presently partitioned. Boot from liveUSB and in a terminal type sudo fdisk -l.
    – To Do
    Commented Nov 23, 2012 at 16:27
  • Please run Boot-Repair and indicate the URL it will display.
    – LovinBuntu
    Commented Nov 24, 2012 at 0:06
  • OK! Thanks LovinBuntu! I actually forgot to mention I tried Boot-Repair before to no avail, but re-tried it and it worked this time! In case you're curious, the URL Boot-Repair output was paste.ubuntu.com/1381109. Commented Nov 24, 2012 at 3:48

1 Answer 1

0

When the booting process is taking place, press the SHIFT key and keep it pressed. Normally, a GRUB screen should pop up and you will choose your OS.

0

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .