6

I want to upgrade Banshee from version 2.0 to 2.6 on Ubuntu 10.04 Lucid. When I run sudo apt-get install ppa-purge I get the error message

E: Couldn't find package ppa-purge.

I am following instructions given in

How do I update banshee to 2.4?

Thanks!

Lou

2
  • I followed your instructions, and version 2.0 of Banshee was downgraded to version 1.6 instead of being upgraded to 2.6 What do you recommend now? Lou
    – Lou Adams
    Commented Nov 24, 2012 at 0:32
  • This is another question - remember to register your account so that you dont have to keep creating new accounts. ppa-purge downgrades your version. That is its purpose. Since what you have posted is not an answer - this has been removed and has been instead converted to a comment.
    – fossfreedom
    Commented Nov 24, 2012 at 10:40

1 Answer 1

3

You are using a command for 11.10+ for 10.04. That might work but more than often does not.

Looking at the packages on ubuntu.com ppa-purge can be found in lucid-backports and not in lucid: http://packages.ubuntu.com/lucid-backports/utils/ppa-purge So you need to add the backports to your sources. Please read the wiki page thoroughly. Enabling Backports Manually can be done by adding the following line to your /etc/apt/sources.list

deb http://archive.ubuntu.com/ubuntu lucid-backports main restricted universe multiverse

After that a (one time)

sudo apt-get update
sudo apt-get upgrade

should update your resource and the apt-get install ppa-purge should work on your system too.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .