I did a fresh Ubuntu 12.04 install on my Sony Vaio laptop, which worked perfectly with 10.04. Now my wireless won't work. I have read just about every Q&A on the subject and I have tried different solutions, including the official troubleshooting guides.

My laptop is equipped with a Intel 5100 wireless device. Ubuntu recognizes the device and it's status is given as connected in nm-tool. I can ping the gateway, my own IP number and localhost. Rfkill shows no soft or hard blocks.

  • I can ping Average time is about 15ms.

Any ideas? I am just a few hours shy of reinstalling good old 10.04!

  • can you ping global dns servers? like google's – Web-E Nov 23 '12 at 10:34
  • Yes, I can ping Average time is about 15ms. – Taake Manning Nov 23 '12 at 10:58
  • so you are connected to internet and speed is also good. wi-fi device is working fine. problem is somewhere else, check the configs – Web-E Nov 23 '12 at 12:55

I have had a similar problem. However it was pointed out (on another forum) that the kernel has been updated and that I should look for an updated driver. My wifi is via a usb dongle so I got the update from Realtek's site.

|improve this answer|||||
  • As far as I am aware (= I can find on intel's site) there are no updated drivers for linux later than 2010. – Taake Manning Nov 23 '12 at 11:02

Please try:

    sudo modprobe -r iwlwifi
    sudo modprobe iwlwifi 11n_disable=1

Does it help? If so, write a conf file:

    gksudo gedit /etc/modprobe.d/iwlwifi.conf

Add a new line:

    options iwlwifi 11n_disable=1

Proofread, save and close gedit.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.