I upgraded from open-jdk to Oracle JDK 1.7 today. Since then my eclipse isn't running. And when I run eclipse i get the following error:- eclipse issue

Below are the logs from the file mentioned in the screenshot:-

buffer@ankit:~/.eclipse/org.eclipse.platform_3.7.0_155965261/configuration$ cat 1353661258260.log 
!SESSION 2012-11-23 14:30:57.677 -----------------------------------------------
java.vendor=Oracle Corporation
BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=en_IN
Command-line arguments:  -os linux -ws gtk -arch x86_64

!ENTRY org.eclipse.osgi 4 0 2012-11-23 14:31:03.518
!MESSAGE Application error
java.lang.UnsatisfiedLinkError: Could not load SWT library. Reasons: 
    no swt-gtk-3740 in java.library.path
    no swt-gtk in java.library.path
    Can't load library: /home/buffer/.swt/lib/linux/x86_64/libswt-gtk-3740.so
    Can't load library: /home/buffer/.swt/lib/linux/x86_64/libswt-gtk.so

    at org.eclipse.swt.internal.Library.loadLibrary(Library.java:285)
    at org.eclipse.swt.internal.Library.loadLibrary(Library.java:194)
    at org.eclipse.swt.internal.C.<clinit>(C.java:21)
    at org.eclipse.swt.internal.Converter.wcsToMbcs(Converter.java:63)
    at org.eclipse.swt.internal.Converter.wcsToMbcs(Converter.java:54)
    at org.eclipse.swt.widgets.Display.<clinit>(Display.java:132)
    at org.eclipse.ui.internal.Workbench.createDisplay(Workbench.java:695)
    at org.eclipse.ui.PlatformUI.createDisplay(PlatformUI.java:161)
    at org.eclipse.ui.internal.ide.application.IDEApplication.createDisplay(IDEApplication.java:153)
    at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:95)
    at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:344)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:601)
    at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:622)
    at org.eclipse.equinox.launcher.Main.basicRun(Main.java:577)
    at org.eclipse.equinox.launcher.Main.run(Main.java:1410)
    at org.eclipse.equinox.launcher.Main.main(Main.java:1386)

You can try OpenJDK 7 also. I think it works with openjdk.

apt-get install openjdk-7-jdk


See if this helps you https://stackoverflow.com/questions/10165693/eclipse-cannot-load-swt-libraries

The solution mentioned there is: For 32bit:

ln -s /usr/lib/jni/libswt-* ~/.swt/lib/linux/x86/

For 64bt:

ln -s /usr/lib/jni/libswt-* ~/.swt/lib/linux/x86_64/
| improve this answer | |
  • my suggestion don't use JDK from OpenJDK cause it still some problems when you compile and run program. In OpenJDK 1.7 update 9, JMenu can't be shown perfectly, sometimes it's hidden when rezises to smaller – obysr Feb 18 '13 at 18:35

It looks like you are running Eclipse 3.7, based on the release notes, it doesn't seem to support Java 7 (1.7.0_09), try 1.6.0_37.


| improve this answer | |

You could upgrade to Juno to fix the issues you face.

To do this you need to remove eclipse 3.7 from your computer. You could also rename it but you have to be quite organised to keep track if you do it that way.

Once you have done this, you can follow the complete install instructions for Juno posted on this blog.

I wrote this myself and I always come back to it when I reinstall my operating system (which is quite often) so I know that it works well and is fairly straight forward, though I should point out this is for eclipse 4.2 and lubuntu 12.10 or 12.04 (although you need to tweak the icon if you are running 12.10).

I have 1.7 and 1.6 on my set up. I choose which path I want when opening a project.

Before you try installing juno please be aware that if your project was set to 1.6 and then you tried to use 1.7 without reconfiguring the build path or exporting it to a new project set to 1.7 this could also be the source of your problem and you might be able to keep using 3.7 after all. (I am not sure because the log file does not tell me what you did to get to that point) Also the other posters may be correct about compatibility, I am not sure but in case you did not try this ( explained this elsewhere on stack exchange but it might be useful to you too so I will repeat it in case you did not already try it:

When you open a project you need to set the environment (which has now changed since you presumably uninstalled 1.6.

If the environment was already set as 1.6 previously and you want it to be set to 1.7 on a project then you will need to make a new project with the execution environment as 1.7 and import it.

java project

enter image description here

Anyway, if you want to upgrade to juno the linked instructions should work fine on ubuntu as well as they do with lubuntu but if you run into trouble just ask.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.