I just installed the new Skype It appears to work fine, except that I've lost the icon in the top bar and the only way to access it is to call it from the dash (very annoying)

Anyone know a quick fix for this or should I just report a bug?


Well, someone already filed a bug for this.

  • if you are happy with your answer you can vote to close your question :-) thank you – Suhaib Nov 23 '12 at 1:20
  • I will in two days (won't let me do it before) Regards. – Gabriel Nov 23 '12 at 11:39

The best method to install Skype on Ubuntu is:

  1. Download the .deb file from Skype official website and install it via Software Manager (don't run skype yet);
  2. Run in terminal sudo apt-get install sni-qt:i386;
  3. Start skype and you will have the icon on top bar too.
  • After executing sudo apt-get install sni-qt:i386 the problem was solved! – EvZ Dec 6 '13 at 16:29

It can be possible by setting the gsetting on the ubuntu by running the command like

 gsettings set com.canonical.Unity.Panel systray-whitelist "['JavaEmbeddedFrame', 'Wine', 'Update-notifier', 'Skype']"

After reboot it will set a icon on the notification bar.

I found a related blog post on Linuxicle: Enable skype notification icon in Ubuntu 12.04/13.04


I solved the problem by skype settings, option --> general: Start Skype minimised in the tray system and set "Choose Style" to GTK+

Restarted skype the icon appeared on the tray!!


Found answer here.

For some reason Skype needs to be whitelisted in order to appear in the top bar. Unity, sigh...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.