0

I am trying to install dangerdeep. after installing dependancies suggested by web site and scon debug I get the message c library gl must be installed. I am working with ubuntu 12.04

0
1

I'm not sure what you tried already... For me it seems like this would solve your problem:

sudo apt-get install libopengl-dev
2
  • unable to locate package libopengl or -dev thanks for trying. – Mark Caron Nov 22 '12 at 16:32
  • 1
    Still it most likely are some missing libs or broken depencies. Whats about "libqt4-opengl-dev" ? Just realized libopengl-dev really does not exists in the repos – seta Nov 22 '12 at 16:38
0

I'm using Ubuntu 14.04 and successfully installed dangerdeep.

I found that if you open ~/dangerdeep/SConstruct with sudo privileges and edit line 263 to only search for libGL.so in the folders /usr/X11R6/lib/, /usr/lib/ and /usr/local/lib/, itsolves my problem.

In Ubuntu 14.04 you can find it in /usr/lib/i386-linux-gnu/mesa/

and add the folder to the 263 line, using:

gllibdirs = ['/usr/X11R6/lib/', '/usr/lib/', '/usr/local/lib/', '/usr/lib/i386-linux-gnu/mesa/']

then try install it again!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.