Ever since 10.04, I can't print to an HP Laserjet P3005. I'm even using an entirely different computer now with a fresh install of 10.10. I've tried with and without the latest hplip.

Recently, sometimes I can get it to print a few things, but eventually it always fails (usually when printing a pdf from the document viewer (also doesn't work with adobe pdf reader)). Sometimes it fails so bad the printer gives an error saying it needs to be turned off and on again.

I can't seem to find a fix anywhere, I've googled all over the past year and tried every fix I could find. It does say that the /usr/lib/cups/backend/hp has failed.

It also doesn't make a difference if I create the printer using hp-setup or Ubuntu's own printing control panel. I delete and re-create the printer, no difference eventually. I use the default printer settings or custom settings, no difference.

I can print perfectly find to a networked printer at home - an HP officejet 6310. It seems to be networked HP printers at work that I can't print to anymore (except occasionally right after re-installing the printer driver).

What's the recommended way to install HP printer drivers and reset or clean out everything from before. Or where are the right logs to read or debug commands to do to find out what may be the real cause of the printing problems?

| improve this question | | | | |
  • Recently, I had a similar problem with my HP Deskjet. Luckily, my problem was resolved by replace with a new USB cable. --FYI – Xiè Jìléi May 26 '12 at 2:40

I have had a few issues with HP printers in the past. The reason I keep buying HP printers is because to some extent they do support open source.

Here is all the issues I have had suggested install as you requested and solutions

Here are a few things that helped me First make sure your printer is supported http://hplipopensource.com/hplip-web/supported_devices/index.html You can check your printer for hplip compatibility I usually check the list before buying a new printer.

Install hplip, Check cups version #cups-config --version to make sure its updated. install sane if its an all in one and you might ever want to use the scanner later.

Sane recommends uncomment hpaio in /etc/sane.d/dll.conf. Running hp-setup as root may help you add your device. (do this)

  • Setting up a static route for the printer. (this usually also is the issue if the computer was saying that it printed but nothing printed, DHCP would assign a new address occasionally and they didnt want to talk anymore.. static makes everything easier) this might be your issue if it works right after you install it again but not later

Other help ... tail /var/log/cups/error_log this will display cups errors newest to oldest.

If you see something like this printer-state-reasons=paused Just resume printing in cups printer admin page.

| improve this answer | | | | |

When my printer had a problem, I didn't find the 'enable' in printer properties because I didn't know to look there. To solve the problem, I opened a terminal and entered the command:

cupsenable "queue-without-quotes"

Background information which lead me to cupsenable:
from http://www.openprinting.org/download/files/beh

# Usually, if a CUPS backend exits with an error status other than zero
# (for example if a printer is not turned on or not reachable on the
# network), CUPS disables the print queue and one can only print again
# if a system administrator re-enables the queue manually. Even restarting
# CUPS (or rebooting) does not re-enable disabled queues.
| improve this answer | | | | |

Try going to system, then printing, then right click the printer, choose properties, then click on policies on the left, then make sure the "Enabled" was checked. It worked for my HP laserjet 1320.

| improve this answer | | | | |

check permissions for /usr/lib/cups/backend. seems like a fuzzy update broke them. assure that backend and executables within have a 755 permission.

| improve this answer | | | | |

Try re installing or re-downloading the package or application.

| improve this answer | | | | |

I have had problems with a HP LaserJet cp3505 and pdfs as well. Although in my case I was sharing the printer with CUPS on a Ubuntu 12.04 server and having problems on a Windows machine when printing pdfs. Using a generic postscript print driver for Windows machine solved my problems.

If you are connecting directly to the printer, then maybe you could try installing a more generic print driver? One that is not specific to your model such as HP LaserJet Series PCL 6 CUPS (en).

If you are connecting to cups shared printer, then try the generic (or HP) postscript driver. Well that is something to try at least. Good luck.

| improve this answer | | | | |

My problem may be related An HP P1102-w. Fails with this "Idle - /usr/lib/cups/backend/hp failed"on every bootup. Solution; Delete the printer; reinstall the printer and start,stop, start again with the power switch. Works every time for me. Simplist of all is to delete the printer before shutting down Then power the printer on/off/on again when you want to use it. Install proceeds faultlessly and remains so until the next boot of the OS when you have to play the delete reinstal game again. This is from personal experience.

| improve this answer | | | | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.