I previously had this working with Ubuntu 10.x, and just recently upgraded to 12.04 (64 bit).

I had installed the driver from Epson: epson-inkjet-printer-escpr_1.2.0-1lsb3.2_i386.deb, and now also tried: epson-inkjet-printer-escpr_1.2.2-1lsb3.2_i386.deb but neither worked.

> sudo dpkg -i epson-inkjet-printer-escpr_1.2.2-1lsb3.2_i386.deb
(Reading database ... 753018 files and directories currently installed.)
Preparing to replace epson-inkjet-printer-escpr:i386 1.2.2-1lsb3.2 (using epson-inkjet-printer-escpr_1.2.2-1lsb3.2_i386.deb) ...
Unpacking replacement epson-inkjet-printer-escpr:i386 ...
cups stop/waiting
cups start/running, process 28199
dpkg: dependency problems prevent configuration of epson-inkjet-printer-escpr:i386:
 epson-inkjet-printer-escpr:i386 depends on lsb (>= 3.2).
dpkg: error processing epson-inkjet-printer-escpr:i386 (--install):
 dependency problems - leaving unconfigured
Processing triggers for libc-bin ...
ldconfig deferred processing now taking place
Errors were encountered while processing:

The issue seems to be: epson-inkjet-printer-escpr:i386 depends on lsb (>= 3.2).

I have lsb 4.0 installed, but maybe it's not the i386 version?

> dpkg -l | grep lsb
iU  epson-inkjet-printer-escpr:i386                          1.2.2-1lsb3.2                                   Epson Inkjet Printer Driver (ESC/P-R) for Linux
ii  lsb                                                      4.0-0ubuntu20.2                                 Linux Standard Base 4.0 support package
ii  lsb-base                                                 4.0-0ubuntu20.2                                 Linux Standard Base 4.0 init script functionality
ii  lsb-core                                                 4.0-0ubuntu20.2                                 Linux Standard Base 4.0 core support package
ii  lsb-cxx                                                  4.0-0ubuntu20.2                                 Linux Standard Base 4.0 C++ support package
ii  lsb-desktop                                              4.0-0ubuntu20.2                                 Linux Standard Base 4.0 Desktop support package
ii  lsb-graphics                                             4.0-0ubuntu20.2                                 Linux Standard Base 4.0 graphics support package
ii  lsb-printing                                             4.0-0ubuntu20.2                                 Linux Standard Base 4.0 Printing package
ii  lsb-release                                              4.0-0ubuntu20.2                                 Linux Standard Base version reporting utility

I have also run sudo apt-get -f install to no avail.

This was for the "Download Printer Driver ESC/P-R Driver (generic driver)"

Thank you!


I have had exactly the same problem. However I found this link :


which suggests that Ubuntu 12.04 is capable of finding and installing printer drivers automatically. Although sceptical, I decided to try with my wirelessly-connected Epson PX730WD. It worked ! I used "System Settings / Printing / Add Printer / Find Printer" (roughly speaking) which found the printer as soon as I turned it on. In fact the drivers it found were for a slightly lower spec device - the PX710W - but so far I have not had any difficulties as a result of this.

I hope you find this useful.

  • It did work! I was skeptical because it had already listed the printer (but perhaps this was due to the USB cable). When I added it from the network it worked. Thank you. – John Lehmann Nov 25 '12 at 23:52

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.