15

On my laptop, Samsung 300V5A-S19 I have the constant noise from the speakers. If I wear headphones, the sound becomes more pronounced (at half volume it mutes the music). The noise level is independent of the volume control. The noise disappears only when volume is completely muted. For the record, the sound is reminiscent of the noise of the waves or something like that.

System information: Ubuntu 12.10, kernel 3.5.0-18

Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 04)

All packages in the system updated.

PS: Following the advice from this message (click) yielded no result.

7
  • 1
    Do you hear a difference when your laptop pluged in/connected to the ground and when it is not?
    – Presbitero
    Nov 21, 2012 at 16:19
  • No. When I was using Ubuntu 12.04 with kernel 3.2, there was a difference between plugged in laptop and laptop working on battery. When the laptop was running on battery, there were quiet clicking sounds every 2 seconds. After the Ubuntu upgrade clicks are gone, but now there is noise, regardless of whether the laptop is connected or not.
    – user103978
    Nov 21, 2012 at 19:24
  • I saw the board, offering to remove PulseAudio, but there was written that should do it only as a last resort. So I hope to solve the problem some other way.
    – user103978
    Nov 21, 2012 at 19:27
  • Do you have alsa setup so that when a mic is plugged in the audio is played through the speakers.
    – David
    Dec 9, 2012 at 22:47
  • What is the connection between the microphone and playback audio through headphones? I have a microphone built into the notebook
    – user103978
    Dec 15, 2012 at 12:27

4 Answers 4

12

The most probable cause of constant noise coming in from the speakers is usually mic boost. In order to disable this:

  1. Open a terminal.
  2. Type alsamixer and press Enter.
  3. Reduce the Mic Boost and Internal Mic Boost to zero. Refer to screenshot.

Screenshot

9
  • 1
    I tried that. It is not the case.
    – titusjaka
    Dec 15, 2012 at 12:25
  • 1
    yes, it's not the case
    – user103978
    Dec 15, 2012 at 12:28
  • It's possible that your microphone input is looped into your speakers. I had this problem when pulseaudio first came out. Dec 16, 2012 at 13:00
  • You were almost right, but instead Mic boost I completely turned off Mic in alsamixer. After that noise has stopped. But the only way to turn it on/off is launching alsamixer, it's not comfortable. Maybe, there is any other way?
    – titusjaka
    Dec 19, 2012 at 16:52
  • 1
    Somehow for me changing the Headphone Mic Boost from 0 dB to 10 dB totally killed the noise. (16.04) Jan 9, 2017 at 23:32
5

The problem goes away after disabling the Auto-Mute mode. Run alsamixer in the terminal, scroll to the right and press up/down to enable or disable Auto-Mute mode

enter image description here

5
  • 2
    Could you please clarify your answer? E.g. how to disable "auto mute mode"?
    – kraxor
    Aug 5, 2014 at 1:23
  • 1
    You can use the arrow keys (up or down), then press ESC to quit the alsamixer
    – duykhoa
    Aug 21, 2018 at 7:17
  • 1
    Thanks. This fix it.
    – Feras Odeh
    Oct 9, 2019 at 8:19
  • Helped me to solve my problem. Thank you, sir!
    – zugzug
    May 17, 2020 at 14:27
  • This answer did the trick for me, i think i accidentally enabled it.
    – Antoni
    Aug 17, 2021 at 10:10
3

I had this problem and solved it by disabling "loopback" in alsamixer. (open alsamixer, and disable the rightmost control)

1
  • This improved but not fully muted. Thanks! Mar 27, 2018 at 10:46
0

That's an open bug. Disabling automute in alsamixer keeps the hiss so it's easier to ignore.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .