46

I have recently gone through this issue. I am running Lubuntu 13.04 in VirtualBox .So when I have maximized and if I would like switch to next window of main system usually we all do ALT+TAB but thats not getting for main system and going for Vbox's Lubuntu .

So how can i get activated main system ALT+TAB functionality even i have a maximized VirtaulBox operating system .

Thank you .

42
  1. Enter into VirtualBox

  2. Press the Host key.

    • The default Host key is the right Ctrl key.
    • On macOS, the default Host key is the right Command key.
    • The previous version of this answer listed the Alt key.
  3. NowALT + TABshould work.

Regarding the Host key from VirtualBox Manual Ch. 1

To return ownership of keyboard and mouse to your host operating system, VirtualBox reserves a special key on your keyboard for itself: the "host key". By default, this is the right Control key on your keyboard; on a Mac host, the default host key is the left Command key. You can change this default in the VirtualBox Global Settings, see Section 1.15, “Global Settings”. In any case, the current setting for the host key is always displayed at the bottom right of your VM window, should you have forgotten about it

  • This is not entirely correct. It looks like you want to press the "Host" key. In the case of those who up-voted this, their host key must have been one of the Alt keys. For me, it's the Right Ctrl key. ron.shoutboot.com/2010/09/11/alt-tab-out-of-virtualbox – Dave Jensen Jan 22 '15 at 4:13
  • 2
    Curious how to accomplish the opposite. Alt tabbing is always swapping Windows applications rather than those within my Ubuntu VM. How does one "undo" this? – kuanb Jan 23 '17 at 17:16
  • 1
    Great, works very well, but just a side node: You have to press and release Host key in step 2, before doing Alt-Tab... – Hartmut P. Oct 1 '17 at 18:27
  • geniuuuuuuuuuus – Damian Lattenero Oct 26 '18 at 22:46
49

My solution: VirtualBox: File -> Preferences -> Input -> uncheck "Auto Capture Keyboard"

  • 8
    This is a great solution when you're working with only one application in seamless mode. Thanks! – Brandon Bertelsen Dec 20 '14 at 21:52
  • 8
    What kind of sorcery is this? I use Virtualbox for YEARS and now you tell I can have a single window just like I'm running an X server on my windows box? This is awesome! – Hugo Dec 20 '16 at 14:51
  • 1
    Love you. It makes for a great development environment: a GNU/Linux VM with all the programming stuff in it and your text editor running. And the terminal using SSH. The reason for having my text editor in my VM is so that it can interact with libs (git, npm, goimports, linters, etc). – tleb Jul 22 '17 at 23:36
  • It's a bit buggy but it kind of does the job. – Nik-Lz Apr 6 '18 at 23:40
  • Super ! Saved my ass !!! – Eric Wang Mar 4 at 11:22
3

Because I use my left hand to do Alt+Tab, I personally set my Host key to be Left Ctrl. This makes it much more easy to switch if you have your right hand sitting on the mouse: press Left Ctrl then Alt+Tab.

  • 2
    For anyone else who stumbles upon this comment and is confused, "Strg" is the abbreviation for "Steuerung", the German name for the Control key. – Eagle-Eye Aug 29 '16 at 18:30
  • 1
    @Eagle-Eye Thanks, I incorporated that into the answer. – wjandrea Oct 20 '16 at 16:28
2

Two part solution:

(1) My solution: VirtualBox: File -> Preferences -> Input -> uncheck Auto Capture Keyboard (taken from @baronbaleron above)

(2) Remap Cycle through open windows to ctrl+tab. In Linux Mint (a derivative of Ubuntu): Start menu -> Keyboard -> Shortcuts -> General -> Cycle through open windows -> change binding to ctrl + tab

0

On MacOS: (Control + ALT) then Tab

In the VM I'm using, I also have to hit Enter after this..which is slightly annoying.

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.