6

I use the inverted colors mode a lot, however after installing ubuntu 12.10 it doesn't work for me any more. The command:

xcalib -i -a

Outputs:

Error - unsupported ramp size 0

I have no clue where to start looking to fix this problem. Couldn't find anything about this error. Any ideas?

4

The gamma ramp is not defined (0), but xcalib expects multiples of 16. Installing gcm solved the issue for me:

sudo apt-get install gnome-color-manager
2
  • 1
    Doesn't work for me. Please explain this method, how have you figured out to install gcm? Maybe I find a similar solution for me. I'm using xfce. Inverting works on 3 different monitors, including the notebook's, but doesn't work on a fourth monitor (Samsung S23B350). – VasyaNovikov Oct 24 '13 at 6:55
  • Doesn't work for me either on Cinnamon. Used to work until a few weeks ago. Using Debian Stretch, not sure what got updated. – Luc Jan 21 '17 at 23:58
2

Here's an idea (I had the same problem with Xubuntu 17.10.1, and this solution worked for me): Use the solution provided in Anwar's answer to this question.

Create the following filepath (I had to make the directory called xorg.conf.d, too): /etc/X11/xorg.conf.d/20-intel.conf and add these lines to the file (then save and restart your computer afterward):

Section "Device"
  Identifier "Intel Graphics"
  Driver "intel"
EndSection

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.