The Ubuntu 12.04 I have installed (in Dual-Boot with Windows 7) using WUBI worked perfectly for over a month. Then it informed me that I ran out of space on the hard drive and I assumed it was because my hard drive on Windows was full. I logged into Windows and deleted the whole New Volume D.

But now the problem is that it is not possible to log into Ubuntu but in Windows it's possible. I really paid attention about not deleting important files in Windows. When i try to log into Ubuntu : _either it does not go far and i have to restart the computer _or it goes until the loading time and a message says something like "[...] Graphics could not be detected [...]" and they ask to choose between 4 options including "Start with poor Graphics", "Reconfigure Graphics", "Troubleshoot" and "Restart the computer". But none of the options run and i also have to restart the computer manually from that point

I have plenty of useful files in Ubuntu so i want to find another way to solve the problem instead of Uninstall/Reinstall Ubuntu. I want to know what happened ? And how to make it work ?

Thank you,

bcbc: Wubi was not installed on D: for sure.

Xtremesupremacy3: just before the problem occured, Ubuntu was saying there was no disk space left (so now I cannot reinstall the grahics driver due to lack of space), I logged in to Windows and deleted all the folders from New Volume D: After that Ubuntu started having problems loading and the "Running in low graphics mode" screen appears every time.

I am trying to update the graphic card driver but I do not seem to be able to install anything due to the lack of storage space. How can I delete files but not all of them to clear up just enough space to get the graphic card driver so I get move on from there?

Thank you in advanc

  • 2
    If you installed Wubi on D: in the first place, then you deleted it. Wubi installs to a virtual partition (a file) \ubuntu\disks\root.disk. Also, deleting files on the partition won't make the root.disk bigger. It's fixed in size except for some special techniques for increasing it. If you deleted this file, then you need to undelete it if you have important data. (If that's still possible) – bcbc Nov 20 '12 at 17:16

Well firstly lets start by addressing the original reason why this happened.

Wubi is often mistakenly seen as installing a Linux partition. In actual fact, a file gets created within Windows (and inside the Windows partition) which acts like an Ubuntu partition. You can view it like being a virtual partition like on VirtualBox for instance. The reason I tell you this is that if that file has become damaged within the Windows environment it will cause problems with Ubuntu.

However, if that was completely untouched and it's purely graphical, then there is a chance that Xorg (graphics in Linux) has to be reconfigured.

Usually this is done by hitting Cntrl+Alt+F2 and typing in 'sudo dpkg-reconfigure xserver-org' at the prompt. Although I have a feeling this might not work with the error appearing.

Just out of curiousity, can you remember exactly what you did or were trying to do inside Windows just before the problem occured?

  • I tried doing this: hitting Cntrl+Alt+F2 and typing in 'sudo dpkg-reconfigure xserver-org' and here's what i got: sudo: unable to write to /var/lib/sudo/user/tty2: No space left on device Package 'xserver-rog'is not installed and no info is available. Use dpkg --info (= dpkg-deb --info) to examine archive files, and dpkg --contents (= dpkg-deb --contents) to list their contents. /usr/sbin/dpkg-reconfigure: xserver-rog is not installed – sacha Nov 21 '12 at 15:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.