I need to run an app on my computer which connects to local port 49100. So everything runs on one computer.

I tried adding rules to gufw, firestarter, manually:

sudo iptables -A INPUT -p tcp --dport 49100 -j ACCEPT

But when I look at opened ports 49100 is not listed! And my app cannot connect to local debugger therefore. I ran:

sudo netstat -anltp | grep "49100"

it returns nothing.


Generally, firewalls don't block local traffic. If your client application connects to port 49100, it expects to find a service (whatever that is) there. So, you need to start the server application (whatever that is) that listens on port 49100 and provides with the service that the client application is expecting to find there.

49100 is not a port associated with a well known service, it is not registered as such at IANA (the organisation that assigns numbers on the internet), so we probably won't able to tell you more unless you tell us what that application is. In any case, you may find some information in that application documentation.

  • You are correct my liege! I just found out there were problems on my client app so it hasn't even tried to connect to server. Now that I've resolved all the internal problems it connects fine. Also, thanks for mentioning about firewalls not interfering with the local traffic! – Primož Kralj Nov 23 '12 at 9:00

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.