11

I was having an error in Update Manager that asks me to do a partial upgrade and it fails. Now I can't sudo apt-get install anything. I tried to fix it, and now I can't sudo apt-get anything. Every time, I get this output:

Reading package lists... Error!
E: Dynamic MMap ran out of room. Please increase the size of APT::Cache-Limit. Current value: 25165824. (man 5 apt.conf)
E: Error occurred while processing libuptimed0 (NewVersion1)
E: Problem with MergeList
/var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_lucid_universe_binary-i386_Packages
W: Unable to munmap
E: The package lists or status file could not be parsed or opened.

I have no idea why this is happening or how to fix it, and I fear that if I try something that probably doesn't work that it will make my problem worse. (Just for reference I am currently running 10.04 (Lucid) on my machine.)

2 Answers 2

21

I believe one solution is just increase the value APT::Cache-Limit at the /etc/apt/apt.conf.d/70debconf, to do so use:

sudo gedit /etc/apt/apt.conf.d/70debconf

and add the following to the end of the file:

APT::Cache-Limit "100000000";

..and then run:

sudo apt-get clean
sudo apt-get update --fix-missing
4
  • This didn't work for me, it still says the same thing but after a longer time Nov 19, 2012 at 23:30
  • 1
    ACTUALLY, I called what was supposed to be 70debconf 70debconfig and misspelled cache... whoops... And after I fixed that, it worked really well! <3 Nov 19, 2012 at 23:34
  • Just as an aside, this is helping me fix a 12 year old computer running a Debian 4.x which won't boot from USB nor optical drive... I'm glad I put on a Debian last time I used it :-)
    – Jan
    Aug 6, 2015 at 20:25
  • 1
    I'm doing a bind-mount of /var/cache/apt in a Vagrant instance (on top of VirtualBox) to a directory output of Vagrant so that I don't have to re-download the packages every time it comes up. It works fine when I bind-mount the archives/ subdirectory, but when I move up a level to mount /var/cache/apt (so that the update cache is kept too), I start getting this error. This fix doesn't seem to change anything. I'm on 14.04 (LTS). Someone else have this issue? Mar 16, 2017 at 22:11
0

Solved after stopping another service (tomcat in my case) using the cache folder.

0

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .