Ubuntu 12.10 - HP Pavilion g4 - AMD Radeon HD 6480G Discrete-Class Graphics

After upgrading to Ubuntu 12.10, I have encountered a random "purple screen after boot" issue.

Here is the nature of the problem:

I turn my laptop on, select Ubuntu in the grub menu (I have a dual boot with Windows 7), then it begins to load with no problem. I see the typical purple screen while the OS boots, and then I hear the logon screen sound, but my screen remains purple. I have tried just about every key combination I can think of to get it to display the logon screen, but to no avail. Folding the lid down, and then back up again does not work either. Because this problem is not consistent, I usually just keep restarting the computer by holding down the power button, and then pushing it to start again. Eventually I will get the logon screen and then be able to work with Ubuntu no problem. Not sure why this issue is inconsistent.

I have tried "nomodeset" in the grub configuration, but that doesn't work either. I also noticed that the screen sometimes looks glitched when I boot or try to even use certain applications. I have also tried installing the proprietary graphics driver, which actually created an even bigger problem: I lost all menus and the screen was totally messed up and had to use the terminal to go back to the open-source driver. The proprietary driver was said to be current for 12.10.


I would try booting with a different kernel version in the grub menu, or into recovery mode, if possible. If that doesn't work it might be worth considering reverting to what you had before the upgrade. Make sure to try the ctrl-alt-T to see if you can at least open a terminal or get some response from the purple screen.

  • I tried booting with a different kernel version, but still had the same problem. I will try with the other ones, and I tried bringing up the terminal during the purple screen, but to no avail. I literally cannot bring up anything at the purple screen, so I am always forced to reboot. Like I said before, this problem is inconsistent, so it doesn't always happen. Thanks for your help! – Matt Nov 19 '12 at 19:38
  • I just noticed that I placed "nomodeset" in the wrong place. I will try it again this time in the right place... – Matt Nov 20 '12 at 7:04
  • Replaced "quiet splash" with "nomodeset". It actually made the computer run slowly and didn't fix the problem, so I reverted back to "quiet splash" for now. – Matt Nov 26 '12 at 20:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.