One of my ubuntu machines, a netbook running Gnome classic on Ubuntu 12.04 (32bit), has a problem: I cannot resize windows. I can unmaximize them and remaximize them, and the resize icons do appear when I place the mouse pointer on the edges, but I cannot grab and resize those edges.

I have googled around and found people with problems like borders being too thin and hard to grab -- this is not the case here. It is also not application specific -- I cannot resize any windows.

What should I look at and fix? I am a developer and can get around a terminal without destroying things fine. I just don't know where to start.

Any ideas?

2 Answers 2


It sounds to me like you're using Gnome-classic with Compiz, and in that case resizing windows doesn't work because the plugin is disabled by default (not sure why).

To enable it, install CCSM:

sudo apt-get install compizconfig-settings-manager

Then run CCSM:


Then in CCSM enable the resize plugin:
enter image description here

If resize doesn't work immediately, you may need to restart Compiz:

compiz --replace & disown
  • 1
    Starting compizconfig-settings-manager did not work for me, but it worked running it trough the menus. After that your solution worked fine. Thanks!
    – DustWolf
    Nov 20, 2012 at 16:56

I had the same problem in 14.04.3, using Unity. Window resize just stopped working in the middle of my workday.

I already had CCSM installed. When I opened CCSSM, "Resize Windows" was already checked.

FIX: By simply unchecking (wait a few seconds, screen flickers a bit), then re-checking "Resize Windows" (wait a few seconds), the issue was fixed for me. No need to reboot or restart anything else.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.