I have got this issue with Ubuntu 10.10. I have been with Ubuntu 8.04 and then decided to try out Ubuntu 10.10 .

I booted with a LiveCD and was able to configure the wireless network painlessly using the livecd. So happily I installed Ubuntu 10.10. As soon as Ubuntu came up it detected the wireless network and I was able to assign a static IP to eth1 (i dont use DHCP option on my ADSL router) and enter a wap key and use pppoeconf to configure the dialer. The net was on and I was able to surf the net. All hunky dory so far. However on the next boot the fun started. It did not detect the wireless network. I could not see the network manager icon in the systray. I used ifconfig and saw that the entry for eth1 was missing. I used ifup eth1 and it said that eth1 was already up .

Then I installed wifi-radar. Wifi-Radar detected the wireless network. I configured wifi-radar for the detected wireless network , set the wap driver as wext and used the manual IP settings. However on clicking connect wifi-radar started looking for a DHCP IP , needless to say it failed. For the love of god I cannot understand why wifi-radar is using DHCP when I have specified manual settings .

Next I decided to use the wired network to surf the net looking for a solution . So I plugged in the network cable from my modem , it detected the plugged in connection , I configured eth0 , used pppoeconf and connected to the net. Then I foolishly decided to reboot my PC. And wonders of wonders , the same problem appeared. I cannot see eth0 in my ifconfig anymore. I used pon to start the dsl-provider connection and it said something about network error or something . Now my ifconfig shows only lo , both eth0 and eth1 have disappeared. Can anybody help me on this?

Is it a problem with ipv6 , if so how do you disable ipv6 on Ubuntu 10.10 ? OR is this is a known issue with Ubuntu 10.10?


  1. I tried Linux mint 10 and had the same issue. On rebooting wireless network was not getting detected .
  2. I have made myself the administrator so that there is no issue of rights or anything.
  • 1
    what's with the downvote favorite remark? up/down votes aren't supposed to be about if you are "happy" about an issue, but if a question is constructive. this appears to be a legitimate concern... Jan 17, 2011 at 10:26
  • If you don't have anything against NetworkManager, you may try and see if things work with that. Check these two questions I posted a while ago: askubuntu.com/questions/9958/… and unix.stackexchange.com/questions/4261/…
    – Mussnoon
    Jan 17, 2011 at 11:43
  • @aking1012 .. i have no clue about the downvote upvote .. i have not touched anything there
    – user9054
    Jan 18, 2011 at 4:45
  • @Mussnoon .... issue solved .. Used WiCD instead of networkmanager and it sorted out things ... seems like NetworkManager has some issues in 10.10
    – user9054
    Jan 18, 2011 at 4:47
  • Possible Duplicate Wired and Wireless Network Issues with PPPoE Jan 18, 2011 at 14:22

4 Answers 4


In order for Network Manager to manage your wireless connection, your wireless interface must NOT be listed in /etc/network/interfaces. But pppoeconf adds it. So what you need to do is remove it.

Edit /etc/network/interfaces by opening a terminal and typing

sudo gedit /etc/network/interfaces

and delete the following lines:

auto wlan0
iface wlan0 inet manual

Restart, and you should be good to go.

  • . yup ... will try this one out .. though i dont get the point of NetworkManager going for a toss when your wireless interfaces are listed in the interfaces file .. i remember my interfaces file containing a entry for eth1(wireless) and network manager working OK in ubuntu 8.04...
    – user9054
    Jan 19, 2011 at 5:15

I happens to me every time I configure pppoe after a fresh install. After the reboot the network connections becomes unmanageable. You need to do the following: open terminal and type:

sudo -H gedit /etc/NetworkManager/NetworkManager.conf

you will find your connection there and changed managed=false to managed=true and then restart you system. You will be able to get your network up and running again


Make sure you've read the Ubuntu documentation on Wireless troubleshooting, which is available at https://help.ubuntu.com/community/WifiDocs/WirelessTroubleShootingGuide/

I've recently had a relative with a similar issue on his laptop. It turned out that the wireless card was disabled, and Fn + F12 had to be pressed to turn it on (it may differ on your computer, e.g. a switch in front of the laptop). The command rfkill list should show "no" twice on Soft/ Hard blocked for "Wireless LAN".

  • the issue was with networkmanager ... installed wicd and its all ok now ...
    – user9054
    Jan 19, 2011 at 5:17

According to the questioner, using wicd solved the problem.

sudo apt-get install wicd
  • I'm writing this as an answer (1) to clear the unanswered queue (2) the questioner has neglected to do so for eight months.
    – djeikyb
    Aug 12, 2011 at 3:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.