As my laptop hard rive was knackered I was adivsed to use ubuntu, it set-up perfectly. But i tried downloading Google Chrome and Flash Player because I couldnt watch any videos and now Firefox has become unresponsive.

It says

Firefox is already running but it is not responding. To open a new window, you must first close the exisitng firefox process or restart your system.

I tried restarting but that hasn't worked.

Ubuntu also asked me if i wanted to do a update which I did, could this be a problem also. When I try to delete the files, it tells me the following:

The link ''lock'' is broken. move it to the rubbish bin.

This link cannot be used, because it's target ';+1885'' doesn't exist

  • Killing the process does not work either.

Open the file manager and press Ctrl+H to see hidden files. GO into .mozilla->firefox and there should be one folder in there, possibly with a very weird name. Now, go into that folder and delete the files lock and .parentlock to allow Firefox to access its SQlite database.

  • would file manager be in file system – James Tweed Nov 19 '12 at 11:38
  • gone into the folder and there's 'crash reports' ido6h0pe.default and 'profiles.ini – James Tweed Nov 19 '12 at 11:42
  • It won't let me delete anything. – James Tweed Nov 19 '12 at 11:45
  • @JamesTweed Press Ctrl+H as .lock is hidden/ – nanofarad Nov 19 '12 at 13:08
  • where's file manager – James Tweed Nov 19 '12 at 18:33

Open a terminal (most likely with Ctrl+Alt+T) or use the dash).

Sometimes the process ID will change by the time you copy and paste it. You have to kill Firefox in single instance. Try this script

ps -aux | grep firefox | awk '{print $2}' | head -1 | xargs kill -9

or more simply

killall -s KILL firefox
  • so the number that came up is 8188 where do i put it – James Tweed Nov 19 '12 at 19:40
  • could you tell me the exact code to put in as it says 'invalid signal specification' am i doing it wrong – James Tweed Nov 19 '12 at 19:47
  • kill -9 8188 that's what you have to enter. – Uri Herrera Nov 19 '12 at 19:48
  • it say's command not found – James Tweed Nov 19 '12 at 19:54
  • The kill command was not found? If you modify what I wrote above to be ps -u $USER -f | grep firefox | awk '{print $2}' you can use the kill command for all those numbers. – philshem Nov 19 '12 at 20:22

Even though the Firefox GUI isn't visible, the process is likely still running in the background. You can see the process number with ps -e | grep firefox and using kill # to kill that process number should allow you to reopen firefox.

  • i done that but still unresponsive – James Tweed Nov 19 '12 at 20:06
  • I reread your question. Are you saying that a full reboot still results in the same message? – data88 Nov 19 '12 at 20:10
  • i've just restarted the laptop and once i restart it says there is file errors do i want to repair, i press F and it goes to the admin section. but i dont have a clue what to do from there – James Tweed Nov 19 '12 at 20:15

Have you tried killing the process with the System Monitor? In the Ubuntu Search, type "sys" and open System Monitor. Find firefox... select it, and click End Process. Hopefully this will kill the process for you and you'll be able to restart Firefox. I've been having a similar problem.


Sometimes the process ID will change, when you copy and paste it. So you have to kill Firefox in single instance. Try this script

ps -aux | grep firefox | awk '{print $2}' | head -1 | xargs kill -9

Do a

pkill firefox 

at the terminal!

  • nope didnt do anything – James Tweed Nov 19 '12 at 19:57

Then go for any newer version of Firefox by these commands.......After connecting it to internet try these commands.....

1.sudo apt-get install firefox(for firefox)

2.sudo apt-get install chromium-browser(for chrome)

3.sudo apt-get install flash-player(for flash player)

  • Two of those three commands have next to nothing to do with Firefox itself. "Going for a newer version" isn't a solution to the problem either. This message persists through the versions, and is fully intentional - even though it is sometimes thrown when not needed. – user98085 Nov 19 '12 at 11:46
  • how do i solve it then – James Tweed Nov 19 '12 at 11:56
  • Ok....I got my mistake..... – str4n63r Nov 19 '12 at 12:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.