I am facing a problem with the dash not showing proper/actual icons for certain applications such as Google Chrome and Mozilla Daily Mail. Instead of getting the standard icons for these applications, I get to see a default icon for all the applications. I have added a snapshot to show the problem.

The icons that are shown in the launcher once launched or in the /usr/share/applications directory are proper. I have tried rebuilding the icon cache, but that did not help. I have also tried switching to other icons themes. This issue does not appear with Gnome Shell or KDE.

I have also tried deleting ~/.local/share/applications/menu-xdg, there was none in the first place.

I am using Ubuntu 12.10. Any suggestions would be appreciated.

enter image description here


The problem is now resolved. Unfortunately, I am not sure how. The last thing I did was deleting the ~/.local/share/applications, but it had no menu-xdg.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.