4

I've googled for 3 days so far, with no success, so I'll be straightforward:

How do you get it to work?

this is the output for lspci -v:

03:00.0 Network controller: Broadcom Corporation BCM43224 802.11a/b/g/n (rev 01)
    Subsystem: Apple Inc. Device 0093
    Flags: bus master, fast devsel, latency 0, IRQ 17
    Memory at c1b00000 (64-bit, non-prefetchable) [size=16K]
    Capabilities: <access denied>
    Kernel driver in use: bcma-pci-bridge
    Kernel modules: bcma

for uname -a:

Linux fury 3.5.0-17-generic #28-Ubuntu SMP Tue Oct 9 19:31:23 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

I've tried with bcmwl-kernel-source, firmware-b43-installer and now I'm out of ideas. Can someone help me? This is driving me insane!

EDIT:

for lspci -nn | grep 0280:

 03:00.0 Network controller [0280]: Broadcom Corporation BCM43224 802.11a/b/g/n [14e4:4353] (rev 01)

I can see the networks available, but when I try to connect, it gets stuck in a loop: tries to connect, fails, tries again, fails again and so on...

EDIT 2:

After a long break from this problem, I've just run a few tests again and found out that, although my macbuntu still fails to connect to my home wi-fi network, it works just fine at my university... Does that help in anyway? My home network is managed by a dual-band (2.4Ghz and 5Ghz) 802.11n cisco e4200 wi-fi router.

EDIT 3 (4 months and a bunch of updates later):

So, now it's working. I did nothing, really, except for updating the packages as suggested by Ubunutu. Now I'm using modules wl and bcma on kernel 3.5.0-26-generic.

  • 1
    I have a very similar problem, except I can't see the networks at all (my network manager indicator says "No network devices available"). My pci.id is exactly the same. – Erland Nov 20 '12 at 16:06
  • the terminal says me b:00.0 Network controller [0280]: Broadcom Corporation BCM4321 802.11a/b/g/n [14e4:4328] (rev 05) What could i do? Thanks – user165391 Jun 7 '13 at 23:41
4

Please run:

    lspci -nn | grep 0280

Is your pci.id 14e4:4353? If so,please do:

    sudo apt-get install linux-headers-generic
    sudo apt-get install --reinstall bcmwl-kernel-source
    sudo modprobe wl

Your wireless should now be working.

If your pci.id is different, please post it and we'll recommend a fix.

  • Yeah, that's the exact pci.id for my wlan device... But now, although it shows the networks available, I'm stuck in a loop (I was before already): it tries to connect, fails, tries again and so on... – Eduardo Bezerra Nov 18 '12 at 20:21
  • 1
    Please make sure no competing drivers are loaded: lsmod | grep -e ndis -e b43 -e brcm. If any are loaded, we may need to blacklist. Did you try a reboot? – chili555 Nov 18 '12 at 21:17
  • So, after a long break from this problem, I've just run a few tests again and found out that, although my macbuntu still fails to connect to my home wi-fi network, it works just fine at my university... Does that help in anyway? My home network is managed by a dual-band (2.4Ghz and 5Ghz) 802.11n cisco e4200 wi-fi router. – Eduardo Bezerra Nov 30 '12 at 17:11
  • If you reset the router to G only, no N, is there any improvement? – chili555 Nov 30 '12 at 22:12
  • So, I just checked that there are no competing modules installed (through lsmod | grep -e ndis -e b43 -e brcm), I've set the wireless router to G-only with 20Mhz-only channel width, and all this to no avail. As the university network is open, I even disabled password protection on my router, and still no improvement... Why does hardware support in linux have to be such a pain? – Eduardo Bezerra Dec 1 '12 at 10:06

Not the answer you're looking for? Browse other questions tagged or ask your own question.