I did something that I don't know and for some reason now I can't click the maximize, minimize and close buttons even resize the window, the title bar just fixes at the top without these buttons and I can't move the window too.

window cannot be closed


What should I do to be able to see the title bar with the buttons again?

EDIT: what i want the window is look like this not the above one.

enter image description here


It happens when the windows-manager is not working. The windows-manager should automatically restart if its process is terminated, but sometimes it don't happen. I first would recommend the system reboot, so the windows-manager would be started automatically by the own system. If it did not happened you could try to run it manually from the Terminal, with the following command:

$ compiz


$ compiz --replace
  • It doesn't work, no luck =( Here is the thread that having the same problem link – CT5275 Nov 18 '12 at 16:33
  • @CT5275 Did you try to follow the answer in the link? It might help you. Sorry but this is what I know and when the same thing happened to me (a bunch of times) it worked. Just marked your question with +1, because it's a good question and I never saw the solution for it on the internet. :) – Zignd Nov 19 '12 at 11:15
  • compiz --replace worked for me however compiz became locked to the terminal I called it in. When I hit CTRL+C I lost all ability to perform keyboard shortcuts or view windows which made life very difficult. Had to look up the keyboard shortcut to force refresh my chromebook which is Power + Refresh key btw for anyone else who had this issue. Best bet is to run compiz --replace & – anon58192932 Sep 28 '15 at 8:07

I found a solution that is available on here under Open Up a Window in Center

It simply works for me and the windows appear as what I want. Now I am able to ALT+Drag the windows, the buttons are showing up too. Fixed

I still consider my situation (before solve) a bug, since I can't Alt+Drag the window, and after restore down the window, the three buttons not showing up as shown in the images under the question. The title bar just fixes at the top without these buttons and causes me to be unable to close some of the windows, this is not normal.

Now, another bug appears, after I start Compiz, I realize that only the Maximize button not showing up, so I just ignore and click into the plugin, then the Maximize button magically appears, I click on it to maximize and click again to restore down, it just disappear again. So far, It happens only on CCSM, I don't know it is normal behaviour or not, just weird. bug


I got the same problem. I'm using Lubuntu 14.10.1 in a Lenovo N500. So i did

metacity --replace

according to 1 and 2 and it worked perfectly :)

enter image description here


If I've got you correctly, you're trying to move that windows hidden by the statusbar, right?

To do so, press and keep the ALT key pressed and then left click and drag the window. You will then be able to click its close and minimize and maximize buttons.

EDIT : If none of these solutions work, file a bug in Launchpad by typing ubuntu-bug ubuntu in a terminal. To bring a terminal up, type CTRL-ALT-T. Then, follow the instructions.

  • no, i cant, :( please see the another print screen i just added – CT5275 Nov 18 '12 at 12:45
  • Are you sure you correctly keeping ALT pressed and clicking at the same time? That should work with Ubuntu 12.10! – Farid Nov 18 '12 at 12:53
  • Yes, it just cant even move around and there should have x _ o (Exit, minimize,maximize) appear when cursor point to the corner but not for mine, why? – CT5275 Nov 18 '12 at 12:57
  • Does the x _ o appear in the statusbar? You could still use the ALT-F4 shortcut to close your windows and add customised shortcuts to maximize and minimize... – Farid Nov 18 '12 at 13:03
  • Nope, not appear in the statusbar, yes ALT-F4 can close the windows, but it does not solve the problem =X – CT5275 Nov 18 '12 at 13:12

Open up a terminal and run

unity --reset

See if it helps

  • unity --reset has been deprecated in 12.10 – CT5275 Nov 18 '12 at 16:36
  • Sorry! hadn't checked that the question was about 12.10. I'm still stuck on 12.04. – Sourav Mishra Nov 18 '12 at 21:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.