72

I configured this:

Automatically check for updates: Never

But the update manager keeps poping up against my wishes, I have no control. I feel like I'm using Windows again.

I want to be able to install updates from time to time, manually.

What can I do?

3
  • Xubuntu 16.04: "Main menu" → "Session and Startup" → "Application Autostart" → uncheck "Update Notifier". Aug 27, 2018 at 19:11
  • 1
    protip for debugging desktop notifications using dbus: dbus-monitor --session "interface=org.freedesktop.Notifications" ... I was having a heck of a time identifying which service was sending the notification signals, this helped tremendously.
    – jmunsch
    Apr 10, 2019 at 18:23
  • the real answer should be to configure system to just perform all system updates silently and automatically with zero popup windows and no interactive questions ... I am trying to setup my grandmothers ubuntu 19.10 box this way and its still not grandmother proof ...yet but there is hope Nov 14, 2019 at 21:06

20 Answers 20

27

Disabling the popups in the configuration seems not to be possible, as told by coteyr in the comments on this page (https://askubuntu.com/a/218780/19753: "It's important to note that other then removing update-manager-core you can't really stop the popup. You can just delay it till something else runs apt-get update" – coteyr Nov 18 '12 at 9:14).

I also wanted to get rid of the popups and of the underlying program that would consume the resources of my Ubuntu 12.04 system on a weak Toshiba AC100 (ARM) -- https://answers.launchpad.net/ac100/+question/214505/.

So the simplest working solution must be removing the "update-manager" (as I've mentioned in the comments at https://unix.stackexchange.com/a/46315/4319 ):

apt-get remove update-manager

I have had no problems after that because I could still use apt-get or synaptic to do package updates.

Useful comments:

antivirtel: on 16.10 it couldn't be removed, since it will remove other packages, like ubuntu-desktop. A possible solution: remove the binary file (/usr/bin/update-manager) or chmod -x /usr/bin/update-manager, and apt hold package to prevent updates (echo update-manager hold | sudo dpkg --set-selections).

mchid: ubuntu-desktop is a metapackage so you can remove it without removing the actual desktop so that shouldn't be a problem.

Dylan Parry: It's probably better to just remove update-notifier rather than the entire update manager. Remember to run pkill update-notifier after removing it (or reboot), otherwise Ubuntu will show an error in the indicator panel.

8
  • 2
    There're no "comments above".
    – Ruslan
    Sep 29, 2016 at 11:23
  • 2
    @imz - on 16.10 it couldn't be removed, since it will remove other packages, like ubuntu-desktop: paste2.org/xHxWLBtf - a possible solution: remove the binary file (/usr/bin/update-manager), and apt hold package to prevent updates (echo update-manager hold | sudo dpkg --set-selections).
    – antivirtel
    Mar 1, 2017 at 22:31
  • 2
    It's probably better to just remove update-notifier rather than the entire update manager. Remember to run pkill update-notifier after removing it (or reboot), otherwise Ubuntu will show an error in the indicator panel. May 30, 2017 at 14:33
  • 3
    @antivirtel ubuntu-desktop is a metapackage so you can remove it without removing the actual desktop so that shouldn't be a problem.
    – mchid
    Aug 31, 2017 at 1:36
  • 1
    @DylanParry Attempt to remove update-notifier will also remove update-manager, so no actual difference.
    – Ruslan
    May 14, 2019 at 9:01
25

Open up the config file that runs the update-manager part after apt

nano /etc/apt/apt.conf.d/99update-notifier

Add '#' infront of the line making it something similar to:

#DPkg::Post-Invoke {"if [ -d /var/lib/update-notifier ]; then touch /var/lib/update-notifier/dpkg-run-stamp; fi; if [ -e /var/lib/update-notifier/updates-available ]; then echo > /var/lib/update-notifier/updates-available; fi "; };

Done.

This worked for me in stopping the update manager popping up after every apt update while still allowing me to run update-manager manually if i wanted to.

4
  • That seems to have worked for me (16.04)
    – trinaldi
    Jan 8, 2017 at 1:13
  • 6
    The comment syntax for this config file is to start lines with // - this solution may work as long as the APT scripts skip the invalid line rather than stopping with a syntax error.
    – RichVel
    May 27, 2017 at 5:16
  • 2
    This didn't work for me on Xubuntu 18.04. I commented out both lines present in the file, but the next day Software Updater window appeared again.
    – Ruslan
    May 15, 2019 at 8:58
  • 2
    This didn't work for me on Ubuntu 20.04. I had to remove update-manager
    – PavoDive
    Oct 22, 2021 at 12:40
17

Just turning off notification of updates will not be enough. There are several background jobs that run apt-get update (including a nightly cron job if I remember right).

To stop the pop-up run update-manager

Then in settings, set Update automaticly to 'Never' and Notify of new version to 'Never'

Sample settings

I suggest leave security at immediately and, setting "others" to every two weeks.

You also need to make sure your not running apt-get update anywhere else. This can happen when you install software, run update-manager, or in a cron job.

If that doesn't work for you:

You can do this by

editing /etc/apt/apt.conf.d/10periodic and changeing

APT::Periodic::Update-Package-Lists "1";

to

APT::Periodic::Update-Package-Lists "0";

Last Resort

You can also do apt-get remove update-manager to remove the feature all together.

8
  • 3
    It's important to note that other then removing update-manager-core you can't really stop the popup. You can just delay it till something else runs apt-get update
    – coteyr
    Nov 18, 2012 at 9:14
  • 1
    Ah, apt-get update is the culprit then. So what do I lose exactly if I remove update-manager-core? I think I read somewhere that it will remove the desktop too if you use unity. Nov 18, 2012 at 9:43
  • 3
    It will remove the desktop 'meta-package'. But that shouldn't harm a thing. It's just a shortcut for installing all the other packages needed for an official "ubuntu" You will loose update-manager. You will need to update manually.
    – coteyr
    Nov 18, 2012 at 10:32
  • 6
    Actually running apt-get remove update-manager-core removes almost the entire system. The proper package to remove is update-notifier: apt-get remove update-notifier which will also remove update-manager-core without pushing further packages to be removed. Cheers! :)
    – Rho
    May 16, 2016 at 15:54
  • 1
    editing /etc/apt/apt.conf.d/10periodic only stop apt-get to check for updates automatically. It won't stop the notification
    – Anwar
    Aug 14, 2016 at 7:40
6

Edit /etc/update-manager/release-upgrades and set:

Prompt=never change this with your favorite editor).

Never use update-manager with -d this checks whether the next release is available or not.

5

You've set it to never check for updates, but you'll find the update manager is opening because it already knows there are updates to be done. Do the updates that it has and it won't bother you again until you update the file lists.

It's a bit like terminal will tell you when there are updates in the apt list that have been put there with 'apt-get update', and will keep on reminding you until you install them.

2
  • Now you make me doubt about whether I've already done this in this particular box. Will try again Nov 18, 2012 at 9:41
  • 1
    This doesn't work for 14.04 (xfce ubuntustudio 64). It checks for updates and reports my computer is up to date.
    – mchid
    May 31, 2014 at 23:23
5

It is good that Ubuntu automatically checks for updates, it is not good that it pops-up windows against your will. You can have less invasive notifications via the gnome bar or from terminal based applications (like Byobu).

To disable the update-notifier while leaving the update-manager automatically checking for updates, run the following from a terminal:

  1. sudo apt-get install gconf-editor in case you don't have it already installed
  2. sudo gconf-editor mind the sudo attribute
  3. search for app->update-notifier and un-tick the "auto-launch" option
  4. close the window
  5. gconf-editor this time as a user (i.e. without sudo)
  6. search again for app->update-notifier and change the "regular_auto_launch_interval" to the number of days you want it to wait before popping-up (0 is immediately, 1 one day, 99999999 basically never again)
5
  • 1
    This sounds like what I need, but I don't have that option. I have 'apps->update-manager', end there is no 'auto-launch' to un-tick. Jan 25, 2013 at 18:32
  • 6
    I do not have update-notifier either (13.04). It seems this instruction is obsolete at least for 13.04? May 30, 2013 at 3:38
  • 1
    If you don't have update-notifier entry, you can use command line: gconftool-2 --set "/apps/update-notifier/regular_auto_launch_interval" --type int 9999 Feb 26, 2016 at 5:40
  • 1
    Doesn't work as of 17.04
    – detly
    May 30, 2017 at 21:58
  • it is not good that ubuntu checks for updates and gives you no choice. checking for updates manually is part of my daily routine on the terminal. GUI popups when not welcome are as welcome as baseball bats to the face
    – pcnate
    Dec 7, 2017 at 5:06
5
pkill update-notifier
sudo mv /usr/bin/update-notifier /usr/bin/update-notifier.real
echo -e '#!/bin/bash\nwhile :; do /bin/sleep 86400; done' | sudo tee /usr/bin/update-notifier
sudo chmod 755 /usr/bin/update-notifier

Brutal, but effective.

3
  • 1
    Why a day-long sleep and not a simple exit?
    – muru
    Nov 5, 2014 at 2:45
  • that might cause problems if the service manager kept restarting update-notifier when it exited. I'm not exactly sure what program it is that manages this "feature". glad that you can still uninstall it without it immediately breaking anything =/, I hope that not having the ubuntu-gnome-desktop metapackage anymore doesn't leave me out of anything like cool programs added to it in the future
    – sig_seg_v
    Apr 25, 2016 at 3:44
  • 3
    This is a solid option but it does not handle package updates. sudo dpkg-divert --divert /usr/bin/update-notifier.ubuntu --rename /usr/bin/update-notifier tells the packaging system that the sys admin has taken over that file.
    – Sean Perry
    May 26, 2016 at 19:44
5

We have installed Ubuntu 20.04 on our local server and installed Lubuntu desktop on it for GUI. We have disabled the update-notifier pop up by uninstalling its package from the server. Below is the command of it.

# sudo apt-get --purge remove lubuntu-update-notifier

I think the above command will be helpful to you.

1
  • Genius answer, thanks.
    – pacify
    Jan 30, 2021 at 14:29
3

For Ubuntu 16.04, and possibly other releases as well:

sudo chmod 000 /usr/bin/update-manager
sudo chmod 000 /usr/bin/update-notifier

Then reboot. (Alternatively, it is possible that merely logging out and back in is sufficient.)

You can verify that update-manager is not running by examining the output of:

ps auxwww | grep update

(Aside: Other posters have suggested sudo apt-get purge update-notifer*. However, I prefer not to remove packages that might be tangled up in the various desktop meta-packages.)

1
  • Hmm, several of these answers seem like dangerous hacks. Aug 25, 2018 at 3:03
3

I do not like automatic updates so I want to disable them always. I use Ubuntu 14.04 with Gnome desktop environment. gsettings may not be available in other Ubuntu flavors.

On slow internet connections disabling apt-xapian-index prevents automatic package downloading which will take all your bandwith (I have 256 kb/s mobile sometimes).

sudo chmod a-x /etc/cron.daily/update-notifier-common 
sudo chmod a-x /etc/cron.weekly/apt-xapian-index 
sudo chmod a-x /etc/cron.weekly/update-notifier-common 

gsettings set com.ubuntu.update-notifier regular-auto-launch-interval 3650
gsettings set com.ubuntu.update-manager launch-time 1900000000

Seemed to do the trick for me. 3650 means days... 1900000000 tells that the update-manager is last run on year 2030 :)

Update: On Ubuntu 16.04 it seems that you are able to disable automatic updates with following commands and by editing two files:

sudo mv /etc/xdg/autostart/update-notifier.desktop /etc/xdg/autostart/update-notifier.desktop.old 
sudo mv /etc/xdg/autostart/gnome-software-service.desktop /etc/xdg/autostart/gnome-software-service.desktop.old

If extension is other than .desktop these commands won't be run on system start.

Edit /etc/apt/apt.conf.d/10periodic

APT::Periodic::Update-Package-Lists "0";
APT::Periodic::Download-Upgradeable-Packages "0";
APT::Periodic::AutocleanInterval "0";

Edit /etc/apt/apt.conf.d/20auto-upgrades

APT::Periodic::Update-Package-Lists "0";
APT::Periodic::Unattended-Upgrade "0";

If you have started Update manager even ONCE these files will contain four lines:

APT::Periodic::Update-Package-Lists "0";
APT::Periodic::Download-Upgradeable-Packages "0";
APT::Periodic::AutocleanInterval "0";
APT::Periodic::Unattended-Upgrade "0";

Just change all values to "0"

2

I am not sure why anyone has not tried this.

I simply disable all checkpoints under "ubuntu software" and "other software" in "software and updates", besides setting options under "automatic updates" and "check for newer version" to "never". This avoids any check up as there is no link, hence no pop-up.

My main pain point was that these updates eat lot of internet data. For people on move, 3G/4G data is expensive and we'd like to optimize its usage. Hope ubuntu understands this concern and provides simpler options to disable updates completely as per user requirements.

1

Ubuntu 16.04 running Gnome Session

You can fix that by removing "Update Notifier" from the "Startup Applications."

First allow it to display in the list of your startup applications.

sudo sed --in-place 's/NoDisplay=true/NoDisplay=false/g' /etc/xdg/autostart/update-notifier.desktop

Then uncheck the item here:

gnome-session-properties

This way you don't need to make any changes in your auto-update configuration (but you can if you want to), rename system files nor remove packages.

1

To disable the popup you must disable the program responsible for displaying them, which is update-notifier.

Stop active update-notifier:

  1. pkill update-notfier

Disable the autostart on login for current user:

  1. cp /etc/xdg/autostart/update-notifier.desktop ~/.config/autostart/update-notifier.desktop
  2. echo "X-GNOME-Autostart-enabled=false" >> ~/.config/autostart/update-notifier.desktop

Tested on Ubuntu 18.04.5

0

I had a similar issue. Executing,

apt-get purge update-notifer*

resolved issue! Ubuntu 12.04.5 LTS

2
  • 1
    This is wrong. First, it's misspelled. Second, on 18.04 (and most likely others since 12.04) it removes ubuntu-desktop*. No GUI means no pop-up, but I doubt that's desired.
    – Lucas
    Aug 21, 2020 at 12:16
  • See my solution in a separate answer. I saw somewhere a suggestion to use equivs to get rid of update-notifier and in my answer is what I ended up with.
    – loop
    Aug 22, 2020 at 20:02
0

To disable the anoying popup after 12.04 had no longer support I did: cd to /etc/apt/apt.conf.d

and edited: 15update-stamp

commented de the original line and added a "fixed" line. My file had:

APT::Update::Post-Invoke-Success {"touch /var/lib/apt/periodic/update-success-stamp 2>/dev/null || true";};

and now I substituted it with:

APT::Update::Post-Invoke-Success {"touch /var/lib/apt/periodic/update-success-stamp 2>true || true";};

Now every time the update is run it is sort of as: "updates where searched for, not found (your system was no longer supported), but it was attempted, everything is as ok as it will get"

0

Replace the update-notifier package with a dummy package to override the component while satisfying dependencies.

equivs-control update-notifier && sed -i 's/.package name\; defaults to equivs-dummy./update-notifier/g' update-notifier && sed -i 's/.short description\; defaults to some wise words/dummy package/g' update-notifier && sed -i 's/. Version\: .enter version here\; defaults to 1.0./Version\: 3.193/g' update-notifier && equivs-build update-notifier && dpkg -i update-notifier_3.193_all.deb

You might need to tune the version number.

0

If the goal is just to get rid of that annoying popup message, it can be done (and undone later) easily. The UpdateManager is just a python package, so: In text editor with root privileges open UpdateManager.py

sudo gedit /usr/lib/python3/dist-packages/UpdateManager/UpdateManager.py

In function UpdateManager.start_available (string # 237) insert return statement, so as the result looks like:

def start_available(self, cancelled_update=False, error_occurred=False):
    self._look_busy()
    self.refresh_cache()

    return   # <<<--- added statement

    if self.cache is None:
        return

    pane = self._make_available_pane(self.cache.install_count
                                     + self.cache.del_count,
                                     os.path.exists(REBOOT_REQUIRED_FILE),
                                     cancelled_update, error_occurred)
    self._start_pane(pane) 

Save the result and that is it.

If later you decide to enable the message back, you just remove that return statement.

0

In Ubuntu 20.04 executing

sudo apt remove update-manager

as suggested by Ivan Zakharyaschev in accepted answer after some time leads to appearing "red circle with a horizontal white line through, it persist on the panel in the top right" as described here.

Reinstalling update-manager removes this red circle warning but it is a bit tricky. Instruction to reinstall it is here.

For me to disable update notifications popups helped the following commands:

  • pkill update-notifier
  • sudo chmod -x /usr/bin/update-notifier

This approach also works in Ubuntu 22.04.

0

In Jammy I had to remove the autostart app. There doesn't seem to be a sensible way to solve the problem.

sudo rm /etc/xdg/autostart/update-notifier.desktop

I suspect it will be replaced next update of update-notifier.

-3

I am using Ubuntu 20.04--the latest Long Term Support version as of January of 2022--and am here to give you the details to stop those annoying popups for good!

This is done with the Terminal. Just perform these steps:

  1. Hold down the Ctrl and Alt keys and press the T key to bring up the Terminal.

  2. The Terminal needs to be elevated to Administrator (root) privileges. To do this, type:

sudo -i

and press the Enter key. You will be prompted for your login password when you do this.

  1. Next, enter this command at the Terminal. What this command does is make the "update-manager" program non-executable and will therefore put an end to those annoying popups for good:

chmod -x /usr/bin/update-manager

  1. Next, type the "exit" command at the Terminal line twice--once to return to normal, non-elevated privileges, and a second time, to close the Terminal.

IMPORTANT: You should still use this Update Manager regularly, since installing software updates are highly recommended. To do this, follow these steps:

  1. Hold down the Ctrl and Alt keys and press the T key to bring up the Terminal.

  2. To gain Administrator (root) privileges, type:

sudo -i

and press the Enter key. You will be prompted for your login password when you do this.

  1. Next, entering this command at the Terminal and will make the "update-manager" program executable:

chmod -x /usr/bin/update-manager

  1. Next, type this command on the command line to update your system:

update-manager

This will bring up the software update screen, which will prompt you to install the recommended software updates. Just allow the updates to be downloaded and installed.

  1. If you are asked to reboot, select the Cancel option. This will close the Software Updates window, and allow you to return to the Terminal command line.

  2. Make the Software Updates program non-executable again by typing this line:

chmod -x /usr/bin/update-manager

  1. Next, to reboot your system, type this command to reboot your system:

reboot

ALSO NOTE, Software updates, after being installed, can leave unwanted files on your system, which simply wastes disk space. To remove these files, you can open the Terminal, elevate the Terminal to administrator privileges, and type these two lines to remove those files that are no longer needed:

apt-get autoremove apt-get clean

After typing these two lines, you can type "exit" at the Terminal command prompt two times to close the Terminal.

Hope this information helps you!

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.