First of, let me tell you I'm a n00b at ubuntu. I have updated my Ubuntu mediacenter to a later version of ubuntu, currently at 12.04. I'm working through a lot of updates to get to the latest. But since my first update I got the new login screen (lightdm?) and my autologin wasen't working anymore. So I Googled how I could make lightdm autologin. I've managed this by making my /etc/lightdm/lightdm.conf look as follows:


Which seemed to work... But now that it automatically logs in, I seem to get the following type of screen (through nomachine remote desktop client):

Sorry... I am unable to post my screenshot here because I do not have the 10 reputation points in askubuntu yet.... darn it...

But the screen has a terminal at the top left of the screen (not an actual "window"), and the ubuntu loading screen is still behind it.

I've tried running startx as you can see. But, this seems to actually be x server. But if I run unity --reset, it seems that a lot of the desktop gets restored, but... with a lot of errors and warnings and the next time I boot, it's the same story all over again. Also, when I close the terminal window after getting my desktop back, I get thrown back at the login screen.

Please bear with my lack of knowledge of ubuntu and it's underlying unix. I thank you in advance.

Edit: I've just tried disabling the autologin and check if logging in with another user would make a difference. First, I get the login screen as expected. Then I login as a different user then the autologin user (btw, if I try the autologin user from the login screen I get the same result as autologin). Then the screen only shows the background, nothing else, when trying right mouse click, I get the option menu to change background etc... Which I also can open. Nothing more, so no terminal at this user, but nothing else either.

Edit 2: I've managed to get the other user working again, by going to terminal (CTRL + ALT + T) executing CCSM. There I only had to check "Ubuntu Unity Plugin". When I did that, the desktop appeared.

So I do have a working user now (even after rebooting). But still, the other user still seems screwed. I tried the above there as well, I needed to enable a lot more of options there. ( as mentioned on: http://www.tuxgarage.com/2011/04/missing-top-and-side-panels-in-unity.html) But still, no progress on this user...


Well... Apparently, it was a lot easier then I thought. (like always) After enabling some settings in CCSM it still did not work for the one user. Apparently, in my ~/.dmrc, there was a line session=xterm. After changing that to session=ubuntu, I managed to fix the problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.