This is 12.04 default desktop (unity). I set it to focus follows mouse, and changed the menus to be on the window. This worked for a while, then some unknown even, maybe an upgrade maybe some other setting change caused it to stop working.

There are many ways for this behavior to start but one reliable one is to bring a window to the foreground/focus with the launcher. Now the focus is stuck on that window and not just the window but the regions within the window so the close, maximize, minimize and menus do not work. I have to use mouse middle and then mouse right and then focus follows mouse is restored for a bit. The exact details of the mouse action aren't clear, sometimes it seems like just mouse middle helps, sometimes just right some times a desperate sequence of clicks :-(

I have tried switching to the gnome desktop and it seems to occur less there but it is not eliminated.

I have tried switching mice to an old wired USB mouse.

I have tried creating a new account and that has not worked.

I have observed "split focus" where to scroll button scrolls one one window but the input goes to another.

I go trapped recently where my keyboard input went to libre office calc, but I was selecting the search term in the chrome address window. The selection "grayed" but the keyboard input for the search went to libre.

Regions in windows have very confused focus. I have to work hard to get focus on for example the close gliph (X) or the minimize gliph (_).

1 Answer 1


This appears to have been a mouse issue.

The system was on a KVM switch and the mouse seemed to work fine on windows (the other computer on the KVM) but not on Ubuntu.

The USB mouse I tried as a substitute did not scroll and that turned out to be why it was on the shelf. Bad luck there.

Once I found out the USB mouse was bad I tried another wireless mouse in exactly the same configuration on the KVM.

Everything immediately started working correctly and I have had no problems for a week.

I cannot explain why the mouse works on windows and not Ubuntu but I cannot call this an Ubuntu issue at this point considering that the mouse had worked on 12.04 for some time.

Advise on mouse issues is check hardware first this way.

Get a verified working mouse and swap out for mouse on problem system and see if this corrects the problem.

Going the other way, taking the mouse from the problem system and verifying it works on a different system may not isolate the issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.