I just got a new Nvidia GTX 650. The huge downside at this point is that whenever I use the open source driver, the computer is ridiculously slow. Whenever I use the proprietary drivers and restart, the desktop wallpaper will load and nothing more. I've tried restarting unity only to get a continuous rolling error. With the CCSM options, unity is enabled, yet nothing appears.

Whenever I'm using proprietary drivers I get a microcode error which happens so quickly that I can't record the number.

  • Have you tried: >compiz --replace in the terminal, or alt+f2 I don't have too much experience here, but after reading your question that's what I would try next. – jason Nov 17 '12 at 4:36
  • Whenever I try to restart unity I get a glXQUERYEXTENSIONSTRING is NULL. – Brendan B. Nov 17 '12 at 13:35
  • what driver are you using? Have you tried starting Ubuntu in Unity 2D? This might get you working. – jason Nov 17 '12 at 17:26
  • Unity 2d isn't even a selectable option – Brendan B. Nov 18 '12 at 2:45
  • I have found out how to fix the issue. – Brendan B. Nov 21 '12 at 13:26

Run this command in a terminal:

sudo apt-get autoremove fglrx --purge

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.