8

My Acer Timeline has a "Disable touchpad button" which works too well. That is, once I've pressed it, pressing it again won't re-enable the touchpad. I've tried a couple of things like:

gconftool-2 --set --type boolean /desktop/gnome/peripherals/touchpad/touchpad_enabled true

which worked once, but now when I do it again, it doesn't work again...

In fact, I'd like to know how to work out what the "disable touchpad" button is actually doing, and why doing it again isn't fixing the issue.

1
  • this is a bug in gconf to my memory, I don't think it was fixed :/
    – RolandiXor
    Jan 26, 2011 at 18:56

3 Answers 3

2

Just load or unload the psmouse module from kernel

for example:

To disable touchpad:

# rmmod psmouse

To enable touchpad again:

# modprobe psmouse

and voila!

1
  • modprobe psmouse does not turn my touchpad back on
    – Seamus
    Jan 26, 2011 at 17:50
0

Try 'gconf-editor' from console and enable touchpad from there.

1
  • 2
    Where in gconf-editor is this setting? (You can edit your answer to provide this information.) Jul 20, 2012 at 22:02
-1

There is a way to do it. When i updated to 11.04 i had this problem. After searching I found a solution. It was by altering some file in the system. What was happening was that the software was disabling the mouse and the hardware was disabling the mouse but once you try to re-enable the mouse the software stays on disable and the hardware works again. All I had to do was make it so that the software keeps the mouse enabled.

2
  • 2
    This answer is not very useful, because it doesn't explain how to do anything, nor does it give any links to resources that would explain it. I recommend editing this to include this sort of information. Jul 20, 2012 at 22:01
  • which file did you changed ?
    – sylvainulg
    Sep 18, 2012 at 8:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.