I was going to add RAM to my notebook to a total of more than 4GB, and I have Ubuntu 12.04 32bit; so I installed the pae version of the linux kernel and booted with it to give it a try before I buy the ram.

My NVidia drivers, which work fine with the normal kernel (as fine as nvidia drivers can work), don't work when I boot with the pae kernel. My second monitor stops working, and when I try to launch NVidia Settings, it tells me that I'm not using an NVidia X Driver.

Now I've rebooted with the old normal kernel and everything works as before.

So, is there some sone bug or incompatibility between the pae kernel and the NVidia Drivers, or will I just need to reinstall (perhaps a different version of?) the NVidia driver if I want to start using the pae kernel?

(which in turn means, will I just waste money if I buy the additional ram?)

1 Answer 1


If you installed the Nvidia drivers with either the Additional Drivers provided by Ubuntu or the downloaded drivers from the Nvidia site, you will need to reinstall them again. This is because (For the proprietary ones) they create a module and set a couple of configuration options that depend entirely on the Kernel in use at the moment they get installed.

Since apt-get does not have a reinstall option like aptitude (eg: sudo aptitude reinstall nvidia-current) we need to use the following commands:

sudo apt-get install --reinstall nvidia-current (Assuming is the nvidia-current you installed)

For the Nvidia drivers from the Nvidia site you are better of uninstalling them, then reinstalling them in the PAE version.

Before doing this you need to start the PAE Ubuntu version in recovery mode. Leave SHIFT pressed until the GRUB Menu appears, then just select Advanved Options and Recovery mode. Try to open a tty1 terminal or going to root then execute the provided reinstall command. that's it.

  • Thanks! That sounds complicated and scary, but "fortunately" I've found out my chipset won't allow more than 4GB at all, so I don't need the pae in the first place! Phew! Anyway, great answer.
    – matteo
    Nov 18, 2012 at 21:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.