I'm using Ubuntu 12.10 32-Bit Edition. I have racently purchased D-link DWA 525 PCI Wireless Adapter. But i can't find the drivers for the adapter. I have been searching in internet for a while. Tried many options, including ndiswrapper.

When i run lspci command, it detects and shows as below.

04:00.0 Network controller: Ralink corp. RT5360 Wireless 802.11n 1T/1R

My kernel version was 3.5.0-18-generic.

After i have upgraded my kernel to 3.7.3-030703-generic and now the device detects as

Network controller [0280]: Ralink corp. RT5360 Wireless 802.11n 1T/1R
[1814:5360]     Subsystem: D-Link System Inc DWA-525 Wireless N 150
Desktop Adapter (rev.A2)[1186:3c05] Kernel modules: rt2800pci

But still there is no sign of the wireless interface in Network Connections window or in iwconfig. And the interface is not functional yet.

The output of iwconfig is

lo no wireless extensions.  
eth0      no wireless extensions.

The output of ifconfig is

eth0      Link encap:Ethernet  HWaddr 00:27:0e:05:5c:e1  
          inet addr:  Bcast:  Mask:
          inet6 addr: fe80::227:eff:fe05:5ce1/64 Scope:Link
          RX packets:38317 errors:0 dropped:0 overruns:0 frame:0
          TX packets:34741 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:38422211 (38.4 MB)  TX bytes:4955007 (4.9 MB)

lo        Link encap:Local Loopback  
          inet addr:  Mask:
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:3499 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3499 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:342593 (342.5 KB)  TX bytes:342593 (342.5 KB)
  • It seems to have been answered here: askubuntu.com/questions/124001/… – jasmines Jan 18 '13 at 10:03
  • What exactly is the output of iwconfig and ifconfig -a now? Again, include this in your answer. – gertvdijk Jan 21 '13 at 19:41
  • Okay, I'm lost here. The kernel module is loaded, but the interface isn't listed. Haven't seen this one before. – gertvdijk Jan 21 '13 at 20:10
  • Will try re-installing ubuntu and upgrading the kernel. My edits with the system configuration or blacklists.conf might have caused the issue. Anyways, thanks for the big help :-) – Hari Jan 21 '13 at 20:13
  • What does dmesg | grep -iE "(firmware|network|rt2800)" show? And you did install the firmware packages as I suggested in my answer? – gertvdijk Jan 21 '13 at 20:17

Background on the support in Linux

It seems that support for this has been added upstream in May 2012 (see this on the mailing list):

[PATCH] rt2x00: Add support for RT5360 based PCI devices.

This chip is used at least by the D-Link DWA-525 adapter.


This was committed in the kernel as commit ccf91bd and has not hit the 3.5 kernel series, unfortunately, but it is in 3.6 and up:

$ git branch -a --contains ccf91bd
  remotes/origin/HEAD -> origin/master

Steps for a solution

Now get connected to the internet first to be able to install packages. Use a wired connection for a while, buy an USB-to-Ethernet thingy if you don't have a wired connection or borrow a well-supported wireless adapter from a friend or neighbour.

Then try to install the backported kernel modules via the package linux-backports-modules-cw-3.6-quantal-generic as well as all the firmware packages: linux-firmware and linux-firmware-nonfree. You should have more luck with this version and firmware files.

If that still fails, try installing a complete 3.6 or 3.7 kernel (reboot afterwards) as I've described in my more general troubleshooting Q&A for wireless issues:

  • My kernel version is the latest provided by ubuntu. its 3.5.0-22-generic. I know that backported kernals are not recommended by ubuntu. Can i still receive official updates if i install a backported kernal?? – Hari Jan 21 '13 at 17:29
  • @Hari Installing a newer kernel on Quantal is unsupported, indeed. That's why I included the compat-wireless backported approach. It's in the official repositories, is supported and you will receive updates, as it's just the kernel modules for wireless devices of 3.6 being backported to the regular 3.5 kernel. :) Only in case that still doesn't work, you can try an unsupported (but still stable!) kernel. I have a strong feeling that just this single package linux-backports-modules-cw-3.6-quantal-generic installation will do the job already. – gertvdijk Jan 21 '13 at 17:44
  • I have tried installing the backported kernel. Doesn't work :-(. Upgraded my kernel to the latest stable one, 3.7.3-030703-generic. Still there is no hope :-( – Hari Jan 21 '13 at 18:29
  • This sounds impossible. It really should work out of the box with 3.6+. Could you post the output of lspci -nnk | grep -iEA3 network in you question? Then I can verify at vendor/product ID level. – gertvdijk Jan 21 '13 at 18:46
  • 04:00.0 Network controller [0280]: Ralink corp. RT5360 Wireless 802.11n 1T/1R [1814:5360] Subsystem: D-Link System Inc DWA-525 Wireless N 150 Desktop Adapter (rev.A2) [1186:3c05] Kernel modules: rt2800pci. Yeah, it detects the card. Don't know why it doesn't shows up in the system. – Hari Jan 21 '13 at 19:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.