I'm new to VNC on Linux and have been following these general instructions to try connect to my Ubuntu 12.04 VPS and view the Linux GUI, but have been getting authentication failure messages when trying to login:

  1. I log in to my Linux VPS and start VNC Server on my Linux VPS:


  2. I then set and verify my password "to access my desktops", which I do.

  3. The vncserver is then started under some new 'X' desktop name, e.g. vps:1
  4. I use nmap to view which port this new X desktop is running on e.g.

    nmap localhost

  5. I run VNC viewer (TightVNC Viewer, RealVNC Viewer) on my Windows 7 PC and connect to the Ubuntu VPS with the given port

  6. Enter my password from step 2. after successfully connecting to the VPS

  7. Get "Authentication failed" messages over and over again.

Going crazy now. Does anyone know what I am doing wrong? I have allowed the VNC Viewers to pass through the firewall, but have run out of ideas now and the above error is still happening.

Thanks in advance.

1 Answer 1


I'm not sure if it's OS specific,but I uninstalled Ubuntu and then installed CentOS and followed similar instructions for setting up VNC client - then everything worked. Unfortunately no definite solution to the original problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.