10

I'm trying to figure out how to disable the right hand side of my trackpad in Ubuntu. The default behavoir is for the right hand side to right click. However, I would like a single click anywhere on the pad to act as a single click, while having a two finger press behave as a right click.

I also have a sony vaio T-series SVT13122CXS and am running 12.10.

Thanks for any help.

2
  • Just wondering if there were any other suggestions?
    – BioGuy
    Commented Nov 22, 2012 at 12:22
  • Edit the title. I thought you were asking how to make touches to the right side of the trackpad do nothing instead of moving the mouse. Commented Jul 10, 2015 at 22:45

4 Answers 4

13

This did it for me: http://kernpanik.com/geekstuff/2015/01/12/disable-rightclick-synaptics.html

For me this disabled the right hand side click area without disabling two finger "right-click".

Essentially, run this:

synclient RightButtonAreaLeft=0
synclient RightButtonAreaTop=0

To persist, add a script that does this into "Startup Applications".

2
  • GREAT! One problem... do you know how I can install synclient? I'm currently using Ubuntu GNOME. Thanks!
    – BioGuy
    Commented Oct 25, 2015 at 9:44
  • WFM! Thanks! @bioguy, on Linux Mint 17.3, it's xserver-xorg-input-synaptics-lts-vivid
    – mrm
    Commented Jan 1, 2016 at 20:21
3

This is what I did: (13 is where my synaptics device was)--I set left, center, and right to left-click, but did not disable scrolling.

xinput set-button-map 13 1 1 1 4 5 6 7 8 9

2
  • 1
    Hrmmm.... sooo close. Scrolling works, and tapping or clicking anywhere on the pad acts as a left click. However, touching the pad with two fingers no longer acts as a right click.
    – BioGuy
    Commented Jan 24, 2014 at 7:38
  • Yes, this method will actually remap both two-finger click and right-bottom-click. At least that happened for me. (I added another solution below) Commented Jul 10, 2015 at 21:41
0

First run the command

xinput

You will get output that looks like

⎡ Virtual core pointer                          id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ Multi-Input Device                        id=13   [slave  pointer  (2)]
⎜   ↳ SynPS/2 Synaptics TouchPad                id=16   [slave  pointer  (2)]
⎣ Virtual core keyboard                         id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
....

The touchpad is the device with ID 16. Check the correct ID for your case.

Then, run the command

 xinput set-button-map 16 1 2 3 0 0 6 7 8 9

where

 16 is in my case the ID for the touchpad
 1 is the left click
 2 is the middle click
 3 is the right click
 0 we disable the scroll up (otherwise it would be 4)
 0 we disable the scroll down (otherwise it would be 5)
 6 ... we leave the rest as they are so we do not disable something important

Now the right side of the touchpad is disabled and does not respond to scrolling.

1
  • Hrmmm... well that almost works. I still want to be able to scroll up and down. Just disable right clicking when I click the right side of the pad.
    – BioGuy
    Commented Nov 16, 2012 at 8:24
0

I found a solution to the same problem on my Thinkpad. I'm sure it'll work on other machines with Synaptics trackpads as well:

https://askubuntu.com/a/572813/366397

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .