Bit of a noob here (clearly). I was having some issues with my server so I tried to restart it, I used sudo halt and now can't access my server to restart!

I didn't forsee this problem, it's a dedicated server but obviously I don't have physical access. How do I start it again?

  • 2
    When turning off a remote server, you will want to use sudo shutdown now to shut down the server, and sudo reboot. sudo halt suspends your computer, which is akin to closing the lid on a laptop.
    – Aaron Hill
    Nov 15 '12 at 19:34
  • When I run sudo halt on my Ubuntu computer, it shuts down immediately without asking questions. It is my preferred way of shutting down the machine because it doesn't ask annoying questions or wait a minute. It still waits (pointlessly in my opinion) for processes to die but one day I'll fix that! Nov 15 '12 at 19:59
  • 1
    Noooo, halt is different then shutdown. And waiting for processes to die is super important. (they may need to finish writing to disk)
    – coteyr
    Nov 15 '12 at 20:18
  • @coteyr: Maybe a DBMS does but KDE, Gnome and most other systems should have no outstanding I/O that they need to do if the system has been idle for the previous minute otherwise they're built broken. (I fail to see why KDE should be writing anything to a permanent file unless I change some setting). If they've written and flushed and the computer has been idle for a minute then the OS will have synced it all to disk. Nov 15 '12 at 20:26
  • 1
    Getting off topic, but halt and shutdown are very different on FreeBSD etc. On Linux halt calls shutdown first then halt. It's important that processes have time to finish writing. A great desktop example would be apt or locate. Also halt (proper) does not unmount file systems. Remember linux always (unless you tell it otherwise) preforms shutdown then halt when you execute a halt. See the man page for more info. TLDR; don't halt, it's just bad, m'ka
    – coteyr
    Nov 15 '12 at 21:47

You're going to have to talk to someone who has physical access. Unless it is running inside a VM in which case the VM owner may have set up a web-based administration tool you can log on to.

  • Check your server's "control panel" there is usually a "force restart" button somewhere. Either that or your going to have to call your COLO tech and get them to push the button. I recommend you switch to VPS systems if you can, they have usually have better management of these rescue situations.
    – coteyr
    Nov 15 '12 at 20:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.